How to keep holiday music from playing in Roon Radio

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Library Size

Description of Issue

tell me how to stop holiday music from playing when I enable Roon Radio. Look at my previous posts for screen shots info ect.

Hi @Mark_McKelvey — Holiday music should only play in Radio if you have started it from a holiday album. If it’s playing incorrectly, it likely means one of two things:

  • The album you’re starting it from is incorrectly tagged as Holiday
  • The holiday content you’re playing is not tagged as Holiday even though it should be

Are the albums that you’re seeing come up as Holiday identified? Are they tagged as Holiday?

As you can see this is something having to do with my wife’s Roon profile. She picked the genre “Vocal” and eventually holiday songs were in the mix. Tagging? I have not done any tagging of my library nor have I created any playlists.

still going on one half year later…thinking Roon doesn’t give a **** about this problem

I don’t think this is quite the same issue.

We have logic in place to prevent Roon Radio from playing holiday music. There may be bugs that we can investigate (@RoonQA) but the content queued in your screen shot was not played by Roon Radio, or there would be a little :radio: icon in the queue.


If you’re shuffling a specific set of content, we don’t automatically remove the holiday content. That’s a fine feature request but it’s different from Roon Radio playing holiday music, which was what the OP was talking about.

If anyone is getting holiday music from Roon Radio, it would be helpful to know what you started Radio on (in the queue, where it says “Playing music similar to…”), and what the holiday content is.

With that info we can investigate more.


Changed genre from Jazz (because it was playing an opera song) to R and B result : a holiday song.

But that’s not from roon radio.

Tell me something. If I choose a genre here in Roon will Roon only play songs from my library and not use Tidal? My library was tagged by Roon when it was imported. So…? Looks like a Roon problem to me.

ok I can now see that. But if you pick a genre from Roon (which imported my library and tagged it yes?) And the first song that comes up is a holiday song (when R+B was chosen) it’s my fault because it’s not “Roon Radio”? It’s taken a half a year of complaining of this problem to get here. Roon cataloged and tagged my library when I set up Roon correct? I’m choosing a genre in Roon right? Then I get an email from Roon saying they are closing out this topic. What does that mean? Does it mean I should f**** off?

Hi @Mark_McKelvey, if you start playback from a genre it’ll play everything associated with that genre, even if that is also holiday music. There are a couple of options here:

  • You can use Roon Radio for the genre which will filter out Holiday content automatically
  • You can use Focus for playback and explicitly tell it not to play Holiday content
  • You can move your Holiday content to a different watched folder and only enable that folder when you want to hear that genre.

Ok now we are getting somewhere. I have a question though: If Roon Radio can filter out holiday why can’t Roon filter out holiday when you choose a genre? After all I am choosing a genre in Roon and Roon is choosing/loading all those songs based on the tagging Roon did when my library was first imported. I’m glad that someone has finally given me some answers but I have been complaining about it for over half a year. That concerns me giving how simple the fix appears to be.

Roon Radio is a bit different than just pressing play — Roon Radio uses Valence to make music choices while pressing play in a Genre isn’t doing anything smart, it’s just saying “hey, play everything tagged with X genre”. Some albums might have multiple genres, so if it is R&B + Holiday, and you chose R&B, it’ll still play since it’s R&B.