How to migrate Roon from QNAP NAS to Innuous Zenith MK3

I just unpacked my Innuos Zenith MK3 which I’m planning on using as my Roon Core moving forward. Is there an easy way to retain my settings, playlists and config from my QNAP Roon or do I have to start from scratch on the Innuos.

My library is currently stored in the QNAP and I was wondering if it makes sense to move everything to the MK3?

Any best practices to follow for integrating these pieces?


I’m going over the but I’d still appreciate any pro tips you might have :grinning:

This is pretty much the way to do it. This is what I did when I use a NUC as a Core. Before I was tinkering my Netgear NAS as a Roon core. But now I use a NUC8i3 for this but I still share my music and film from the NAS.

Thanks it seems pretty straight forward. I‘m still trying to decide if I should keep the Library in the NAS or import it into the MK3, any pros/cons for these?

Also, the Innuos setup allows 3 different Roon configs: Core, Roon Player or Roon Core with Squeezelite.

I picked Roon Player to compare against the Node2i feeding my Hegel Right now but I can’t get Roon to see the MK3, what am I missing? Do I have to restart Roon?

I updated Roon on the NAS and restarted it and still doesn’t show the MK3 as a player. Is there a way to force Roon to scan for new devices on my network?

It took a while but it’s now showing but the settings and Device setup screens are inconsistent.

One shows Zenith and ALSA as “identifiers” and the other one shows Hegel H590 USB and unidentified device. Any ideas why?

See pics below:

And after a couple of days playing just fine, the MK3 player disappeared from Roon once again. Any ideas how to force Roon to rescan my network and keep the device in the list?

This is a very weird behavior and looks like another bug. I rebooted my NAS / Roon and the MK3 was still not showing.

Then I changed the Hegel to USB input and all’s of the sudden the MK3 is back. What’s the deal? Why is Roon not keeping the device in the list?

This is getting worst. I decided to change DSP EQ settings and Roon completely stopped playing. Now it won’t play regardless of going through the MK3 or the BlueSound Node2i.

If I go through the BlueSound app or Spotify, the music plays fine but Roon is stuck and although the Play/Pause button seems to respond to touch nothing plays.