How to set up a FLIRC remote with Ropieee XL?

Can someone please explain it to me like I’m a 6 years old how to set up a FLIRC remote control with Ropieee XL?

Here’s what I’m doing - am I missing any steps, or doing anything wrong?

  • insert the Flirc dongle into windows computer
  • Fire the FLIRC app
  • it says ‘connected’ in the lower right
  • open controllers/media keys
  • select a button on screen
  • press remote button to pair with - the app says recorded successfully or something like that
  • repeat for all buttons on the remote
  • save configuration (saved to a file, didn’t seem to help). Not sure if there is some step to save configuration to dongle?
  • pull dongle from windows PC
  • insert dongle into Ropieee Xl pi
  • reboot

The remote control page in Ropieee is identifying the Flirc and is set correctly (name of zone exactly as in Roon). Also the extension is enabled in Roon.

However it does not work. I repeated this process several times, as far as I can tell all settings are correct and the dongle is not deffective as it registers remote clicks when setting up…
If it matters, the remote is an Apple TV old style remote.
Any help is greatly appreciated.

https://www.google.com/search?q=apple+tv+remote&rlz=1C9BKJA_enRO885RO885&hl=en-GB&prmd=isvn&sxsrf=ACYBGNTjJAjbmt3TmNO02opEU0nLMDk3LA:1581351594532&source=lnms&tbm=isch&sa=X&ved=2ahUKEwjagbrgscfnAhWoD2MBHTEFAKcQ_AUoAXoECA4QAQ&biw=1112&bih=725&dpr=2#imgrc=FQlx4aGXNjbySM

Later edit:
@spockfish if I add a remote after the initial install do I have to re-flash? This would be surprising since the OS sees the remote already…

It’s the only thing I haven’t tried but I would like to make sure that this is the reason it’s not working.

No need to reflash.

I suppose your mapping is not working as this comes rather precise.
So for controller you should use ‘Media Keys’.

That’s what I used…

Can you reboot your unit, pres a few keys and send feedback afterwards?

I would like to understand how Roon transport control works.
If I use the Flirc dongle in Windows and map the media keys to it, Roon doesn’t respond to any of them. If I map the Roon keyboard shortcuts they work - Ctrl+K for next, Ctrl+up for volume up, etc.
If I move the dongle to the Ropieee with either set of keys mapped it does nothing.
Is Roon supposed to take media key commands from Roon Bridge but only Roon specific key combos from the windows controller?

Either way I cannot seem to make it work.

Tried with a different remote, same result
If I send to logs are you able to see if the correct commands are recorded in the dongle?

Feedback sent e0ee44dd6b734b02

Hmmm… the unit is indeed recognized, but the the main process responsible for handling actual input fails. Unclear why.

I’ll dig up my Flirc and do some debugging here to see what could be wrong.

Thanks

1 Like

Here’s the conversation with the developer of Flirc Jason Kotzin, maybe it helps
He says that the keys are almost certainly mapped correctly.
Hi Dan -

Yes, it’s hard to ‘capture’ those keys. So unfortunately, the GUI wont lightup for every key. Those specifically. They should definitely be paired. Let me know if that helps.

Sincerely,
Jason Kotzin

\ 40x40 Dan Matiesanu

*Feb 10, 14:05 PST *

Hi Jason

But I have a problem with another device which is Using the media keys controller. I am afraid I cannot make the Flirc dongle ‘take’ the media keys
*I understand that when a key or key combo is mapped to a remote button, and I open the controller on the GUI, the key combo should light up in green when pressing the remote button, right? I see this happening with key combos from the full keyboard controller but not with media keys. They do seem to map all right (the GUI says ‘recorded successfully for each of them) but then the buttons don’t work. *

I hope I explained it clearly… any suggestion how to fix this?

This is not how the Flirc interacts with the Roon product.
As stated earlier, something is wrong with the supporting processes and I need to dive into that.

@spockfish
Thank you for your help - For me this is not needed anymore since I will not use Flirc or Ropieee.

Hi! I am reviving this thread because it seems like I’m having similar issues with Flirc and Ropieeexl.

Flirc seems to be configured properly using my MacBook with Media Keys, and responds to keypress from remote on the same MacBook running Roon as a remote.

When I plug the Flirc into the Pi, however, remote keypresses do not function.

The logs show that keypresses are being registered, but there’s an error with MQTT

Any help will be appreciated!

Feedback…

74da4fcac35f7ab9

I suspect you did not enable the RoPieee Remote extension in Roon…

Aha! Oops! All that digging through docs and I missed that the remote extension had to be enabled in Roon. Works great now. Thank you, Harry!

Hi. Resurrecting this thread, as I seem to have the same issue as the OP.

In my case, I used the Boxee controller profile. But as with the OP, the Flirc dongle recorded the inputs when plugged into my Mac fine, Ropieeexl recognises the Flirc, the extension is enabled in Roon, the zone is set in Ropieee as a copy & paste of the zone name in Roon, and so on.

As mentioned above, I’ve tried rebooting the Pi, pressed a few buttons on the remote, and sent feedback - id code 5e4356bcb0f63580

Hope that shows up something useful.

You should not use the Boxee controller profile, but the generic media profile.
And, is the extension enabled?

Aha, that worked, excellent. And thanks for the swift response.

FWIW I only used the Boxee profile as that’s what’s recommended by Hans Beekhuysen in the video that led me to try Ropieeexl here (I also followed his advice about donating, so you may owe him a beer :slight_smile: ).

I’ve left a comment on the video mentioning that the media keys profile should be used instead. Hopefully that’ll help anyone arriving via the same route.

Where can I find the RoPiee Remote Extension?

I figured it out, I had to run the Roon Remote extension, then the Ropiee Remote Control v2 showed up. If this was documented I must have missed it.