How to stop Roon from adding albums from Tidal

Hey. I only want albums to show up in Roon from Tidal that I select. . .as it works now it appears that Roon is adding a bunch of albums based on my collection of actual musci and what it thinks I want. . .for example. I have several Bob Dylan albums. Roon is adding dozens (I don’t like Bob Dylan and won’t want any added to my library). Similar things are happening. . .

I only want Roon to show the albums I own from my NAS and the albums I specifically added to my library in Tidal. How do I do this?


See if this helps.

When you setup Roon it asks if you would like to add collections from Tidal and defaults to selecting one for you unless you untick it. A number of people (including me) have raised this default behaviour with the devs, but it doesn’t appear to have been changed yet.

If you Focus/Inspector/Storage Location/Tidal and then filter with the Added tool you should be able to focus on all Tidal albums added to your library on a particular date. Then select all (Ctrl-a), Edit, Delete Album to get rid of them. If that removes some albums that you want you can add them again individually.

Thanks - but when I select and press delete I get “Can’t jump. You can’t quick jump using that sort”. How to I delete a selection?


Hi Adam,
Have you read the post that Phil linked to? In that topic Kevin describes in detail how to do it.
Have read and if your still having trouble get back to us.