How to switch Shuffle off? [Answered]

Since today the shuffle indicator keeps staying on the main screen. How can I remove it?

Not sure I fully understand the complaint. Would you mind to demonstrate with the screenshot ?

Why would you want to? It’s just an option to shuffle through all of it as far as I can tell. Select an album or an artist and you can choose anything. Thoughts, Chris

Well, my problem is that I want to determine myself which album to listen to. As it is now it is the ‘shuffle button’ that makes choices. In Roon settings I tried already to block the shuttle and radio buttons. However, the shuttle sign in the main screen stays active and continues to work.

The shuffle indicator (on the main screen) doesn’t do anything unless you click it. There’s no turning on or off there, unlike the shuffle indicator in the queue screen,

I know, it’s a little confusing.

1 Like

You can choose the album, just select it…

The shuffling just keeps going. I would greatly acknowledge if this option is converted into a ‘real option’ (I mean something that can be switched off).

I’m sure I am missing something here. You can alternate shuffle with the arrows to the right of the play line. Is this the problem?

Do you have 'Radio" on?

Also, it looks like you have to click 'Shuffle" again and then pick 'Undo" to turn shuffle off.

Kind of clumsy.

Hey @Wouter_Beertsen – there’s a couple things you might be talking about, so let me see if I can clear things up.

Shuffle Buttons

On screens where there are a variety of ways to play, we let you customize those options however you prefer. This includes screens like playlists and albums, where you might want to play the content in order, or you might want to shuffle it, add it the queue, and so on.

There are a number of screens where the only available options are Shuffle and Radio. This includes browsers (like the Album browser below), as well as screens like Genres, Artists, etc. For the moment those screens cannot be customized, mostly because we only offer two play options.

If you want to play everything on the screen you can shuffle everything or start Radio (which will play similar content).

If you want to play specific albums you can click them and play them from the album screen, or you can select them.

Note: In 1.4, the “Play All” button was relabeled to “Shuffle” – it does exactly what it used to do, and other than the text on the button there haven’t been any changes in this area.

Enabling/Disabling Shuffle Modes

If you’re talking about turning off Shuffle modes these are the two places you want to check.

If the shuffle is off (white) and Radio is off, only tracks you explicitly pick should play in order.

If you shuffle a set of content, you can end the “Shuffle” here:

17 posts were split to a new topic: Shuffle Confusion

Slim, this is what I got out of his complaint. The blue shuffle button appearing when an artist was selected. Maybe the OP could post a screenshot.


Sorry for having no time to respond earlier to your messages. I just returned to my music and guided by your suggestions have been able to turn out radio and shuffle. Thanks a lot!