How to use iPhone's roon app to transfer audio device

Core Machine

Windows 10 enterprise
-Processor: Intel(R) Pentium(R) CPU @ 3.20GHZ 3.20 GHz
-RAM: 8.00 GB
-System: x64

Network Details

Ehernet(with ability of download speed of 1000Mbps and upload 100Mbps)

Audio Devices

mostly NAD M10, NAD T778, iPhone 12 pro, iPad six generation–

Library Size

17,000 tracks

Description of Issue

I used my iPhone 12 pro’s roon app( Roon version 1.8(build 795) (64bit)[iPhone’s operating system of 14.6] and I tried to transfer my music playing to another device, I found that I could not, unlike my windows 10 PC and my iPad, which I can transfer easily. So I made a group of the current-using device with the device that I wish transfer to. Then I push stop button and ungrouped them and then I use the device that I wish transfer to. The process is quite troublesome.
Do I missing something here? In other words, is the app already built with the function of transfer audio devices and I missed it. Or currently roon app in iPhone does not have this function of transferring audio devices. If this is correct(the current app in iPhone does not have this function), could you tell me the following :

  1. When will the app in iPhone have this function of transferring audio devices?
  2. Before you add this function in you app, can you provide some easy way to transfer audio devices on iPhone at this moment?

Thanks for your reply.

1 Like

It’s not there [grafik] when you click on the speaker symbol bottom right?

I am not sure what you mean. There is no right touch function on iPhone and other cellphone, I believe.

Then do a left touch on the speaker symbol.

I am not sure what you mean. There is no left touch function on iPhone and other cellphone neither, I believe.
Bye the way, I found by pressing hard on the speaker symbol on my iPad, a line of " transfer to other audio devices" show up and can be touched, but I can not get anything by pressing hard on the speaker symbol on my iPhone.

Have you tried rebooting the phone? My wife’s iPad does this sometimes with the Roon app, taking ages to respond to a long press and having a laggy response. A reboot fixes it. Could be an IOS issue or a Roon app issue.

I rebooted my i Phone and nothing changed. In other words, hard pressing speaker symbol in roon app resulted nothing. But thanks anyway.
One question, what model of iPhone does your wife use and what the operating system is?

It is an iPad about 5 or 6 years old so not likely to be on the very latest IOS. I will check and report back later.

Don’t bother.
I have an iPad ( six generation) and it works fine in term of transferring audio devices on roon’s app . What I have problem is my iPhone 12 pro.

So the problem is not that the feature is not there, but that the phone doesn’t react on a touch on the speaker symbol ? Does the phone register a touch on the same region in other apps?

I am not sure the problem is due to that the roon app on iPhone does not have the function of transferring audio devices ,or the app’s problem .or the iPhone’s problem. It requires some tech staff of roon app to answer.

I have no answer to your second question.

Lower right hand corner is the speaker. Tap that.

Brings up menu of:

  • Moon DSP TwoArrows Gears

The TwoArrows is transfer. Tap on that. You select the destination.

You don’t need to stop the music before you do this.

If you don’t have the TwoArrows (@BlackJack posted a picture first response same icon as desktop) then it’s probably a bug. Try reinstalling. The feature is there and it works I just tested it.

It would be helpful if you take a screenshot of what you’re seeing.

I got it. It is there already,by taping the speraker sign(with “))” mark) at the lower right corner. When @BlackJack told me, I thought he referred to the picture of cellphone. Thanks you and @BlackJack and wish you the best.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.