How to use ROON & Lumin Mini NOT via airplay?

Roon Core Machine

Mac mini Apple M1 (2020), MacOS Monterey 12.01, 16 GB

Networking Gear & Setup Details

Mac mini (WLAN deactivated) via LAN → tp-link TL Sg108e switch connected to
→ Netgear JGS524Ev2 24 ports switch

Connected Audio Devices

Roon core via LAN → Lumin Mini
Lumin Mini via USB to RME ADI -2 Pro FS R (Black Edition )

Number of Tracks in Library

7.000 tracks + qobuz

Description of Issue

I am a ROON newbie and managed to install and run ROON successfully. Yet, using my Lumin mini as end point via LAN, the signal chain in ROON indicates that I use the Lumin mini via airplay (see screenshot below). From my understanding this is not the favourable way. I found no way to modify the airplay-streaming mode. Can anybody point me to any information on how to change this or to understand if I am chasing ghosts ?

Best regards

What do you have enabled in your settings: audio device?
Can you post a screenshot of what you see in audio device page?

Thought so.
You need to disable the airplay lumin bottom right.
Then enable the Ethernet lumin mini under Roon Ready
You should be set then


Thanks, found a solution. When omitting the second switch, a second LUMIN device appears. If I choose this one, transport is being displayed as running native.
Thanks for looking into this anyway…

1 Like

You may be able to still use the Netgear switch if you disable IGMP snooping: Default IGMP settings may affect multicast streams on NETGEAR Web Managed Plus Switches | Answer | NETGEAR Support

IGMP snooping, at least as implemented by some Netgear managed switches, is not friendly to Roon, which uses unrestricted multicast to discover remotes and endpoints.