HowTo: Install extensions on Windows in three easy steps


(Jan Koudijs) #1

This HowTo describes how to install Roon extensions on a Windows system.

The provided installer installs the Roon Extension Manager as a Windows service. When the extension manager is running you can install and uninstall extensions from within the Roon UI, select Settings->Extensions from the “hamburger menu” in the upper left corner and select the extension manager.

The service takes care that the extension manager starts when Windows starts, it is not necessary to login for the service to run.

The installation consists out of three easy steps (at least that’s the idea):

Step 1: Download the installer

Visit the latest releases page of the installer and download the executable for your Windows variant (32 or 64 bits). Please also read the information above the download links.

Step 2: Run the installer

Run the installer as administrator, this is necessary for the service installation.

Installation video:

Step 3: Install the extensions of your choice

Usage video:

Important notes!!

  • Use the installer and extensions at your own risk!
  • Make regular backups of your Roon database.
  • The installer and extensions are in beta status, as is the API they depend on. This means that there can be small or even bigger issues!
  • Tests are performed on Windows 10 but the installer should work on Windows 7 and above.
  • If something goes wrong during installation please copy the text from the installer command window, post it in this thread and tell which Windows version you’re using. The command window should stay open till you press a key.

Special Thanks

A special thanks to @wizardofoz for being of great help in getting the installer up and running!


How to Install Roon Web Controller extension on ROCK?
Roon Extension Manager v0.10.0
Roon Extension: Denon/Marantz AV receiver volume control (GitHub)
HowTo: Install Roon Extension Manager on macOS
(John B) #2

Okay so I’m one of those “non-Geeks” @wizardofoz mentions that Roon API may be now accessible to, so I’ve just taken the plunge and well, it’s a pretty foolproof standard windows installation. Thanks @Jan_Koudijs for this great addition to Roon.

I installed the alarm and set it up for 5:20 alarm and a 5:56 stop and, hey, it just worked.

Greta work and many thanks.

.sjb


(Mr Fix It ) #3

Jan certainly put in the effort to get this to a point of a workable install for the extensions supported. Personally I find the Alarm the most useful, but some will also get some good mileage from the web based controller too. I haven’t tried the other ones yet.


#4

Another successful windows 10 x64 installation here. BTW, I already had Git and node installed, but it still seem to download them at the start of the install (not that it caused a problem, just mentioning in case not intentional)

Now, just need to find a way to install and run on my sonicTransporter i5 now and do away with the PC altogether…

thanks very much @Jan_Koudijs
Nick


(David Orgel) #5

One really nice thing about the Web-based controller is that it allows you to use devices that can’t run Roon Remote (e.g., older iDevices) as Roon control points.


(Mr Fix It ) #6

Indeed I have used the web interface on my old iPad 2 but of course it’s not roon per se but the now playing screen is certainly good. I seldom need the web interface with my other iOS devices being the norm but it’s a nice to have for sure if you have no other options

As for the Logitech and Marantz/Denon I have no means to test.


(Jan Koudijs) #7

You are right, now that the installer is working the next step is to make it a bit smarter :slight_smile:

The ultimate goal: Get it preinstalled on sonicTransporter, ROCK, Nucleus…
(…end of daydream)


(Geoff Coupe) #8

@Jan_Koudijs - I’ve got this installed following your instructions. Very promising! Now, where can I donate?


(Jan Koudijs) #9

Thanks @Geoff_Coupe.

No facility for donations at the moment, at least not financially, but you can always donate by spreading the word :wink:


#10

I’m under the impression that @agillis is looking into how this can be added to the SonicTransporter.


(Jan Koudijs) #11

That would be nice!


(Andrew Gillis) #12

It shouldn’t be to hard to get this working on Sonicorbiter OS (sonicTransporter). I’ll look into putting this into the next release.


(Jan Koudijs) #13

Hi @agillis, thanks for stepping in, and of course for considering this for the next release!

On a Linux system it is basically the installation of two extensions (the manager and its updater), these then have to be glued together via a simple script and the script can then be started from a systemd service.

It is still on my list to provide installation instructions and support files for Linux.


(Niccolò Terzi) #14

sorry if this is not the right place.
one week ago, i installed the manager, and everything war really OK!
then, 2 days ago i (by error) unistalled nodes.js (OS windows).
and the manager disappeared.
when i realized the problem, i tried to re-install, but now it doesn’t work anymore.

so, this is the logfile, maybe someone can help me :slight_smile:

0 info it worked if it ends with ok
1 verbose cli [ ‘C:\Program Files\nodejs\node.exe’,
1 verbose cli ‘C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js’,
1 verbose cli ‘install’,
1 verbose cli ‘-g’,
1 verbose cli ‘https://github.com/TheAppgineer/roon-extension-manager-updater.git’ ]
2 info using npm@3.10.10
3 info using node@v6.11.1
4 silly loadCurrentTree Starting
5 silly install loadCurrentTree
6 silly install readGlobalPackageData
7 silly fetchPackageMetaData https://github.com/TheAppgineer/roon-extension-manager-updater.git
8 silly fetchOtherPackageData https://github.com/TheAppgineer/roon-extension-manager-updater.git
9 silly cache add args [ ‘https://github.com/TheAppgineer/roon-extension-manager-updater.git’,
9 silly cache add null ]
10 verbose cache add spec https://github.com/TheAppgineer/roon-extension-manager-updater.git
11 silly cache add parsed spec Result {
11 silly cache add raw: ‘https://github.com/TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add scope: null,
11 silly cache add escapedName: null,
11 silly cache add name: null,
11 silly cache add rawSpec: ‘https://github.com/TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add spec: ‘git+https://github.com/TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add type: ‘hosted’,
11 silly cache add hosted:
11 silly cache add { type: ‘github’,
11 silly cache add ssh: ‘git@github.com:TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add sshUrl: ‘git+ssh://git@github.com/TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add httpsUrl: ‘git+https://github.com/TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add gitUrl: ‘git://github.com/TheAppgineer/roon-extension-manager-updater.git’,
11 silly cache add shortcut: ‘github:TheAppgineer/roon-extension-manager-updater’,
11 silly cache add directUrl: ‘https://raw.githubusercontent.com/TheAppgineer/roon-extension-manager-updater/master/package.json’ } }
12 verbose addRemoteGit caching https://github.com/TheAppgineer/roon-extension-manager-updater.git
13 verbose addRemoteGit git+https://github.com/TheAppgineer/roon-extension-manager-updater.git is a repository hosted by github
14 silly tryClone cloning git+https://github.com/TheAppgineer/roon-extension-manager-updater.git via git+https://github.com/TheAppgineer/roon-extension-manager-updater.git
15 verbose tryClone git-https-github-com-TheAppgineer-roon-extension-manager-updater-git-23b1203c not in flight; caching
16 verbose correctMkdir C:\Users\nicco\AppData\Roaming\npm-cache_git-remotes correctMkdir not in flight; initializing
17 info git [ ‘config’, ‘–get’, ‘remote.origin.url’ ]
18 silly validateExistingRemote git+https://github.com/TheAppgineer/roon-extension-manager-updater.git remote.origin.url: https://github.com/TheAppgineer/roon-extension-manager-updater.git
19 verbose validateExistingRemote git+https://github.com/TheAppgineer/roon-extension-manager-updater.git is updating existing cached remote C:\Users\nicco\AppData\Roaming\npm-cache_git-remotes\git-https-github-com-TheAppgineer-roon-extension-manager-updater-git-23b1203c
20 info git [ ‘fetch’, ‘-a’, ‘origin’ ]
21 error git fetch -a origin (https://github.com/TheAppgineer/roon-extension-manager-updater.git) error: inflate: data stream error (unknown compression method)
21 error git fetch -a origin (https://github.com/TheAppgineer/roon-extension-manager-updater.git) error: unable to unpack a1d0fe355d809ba93f4ad4975d162a82fb91d423 header
21 error git fetch -a origin (https://github.com/TheAppgineer/roon-extension-manager-updater.git) error: inflate: data stream error (unknown compression method)
21 error git fetch -a origin (https://github.com/TheAppgineer/roon-extension-manager-updater.git) fatal: loose object a1d0fe355d809ba93f4ad4975d162a82fb91d423 (stored in ./objects/a1/d0fe355d809ba93f4ad4975d162a82fb91d423) is corrupt
21 error git fetch -a origin (https://github.com/TheAppgineer/roon-extension-manager-updater.git) fatal: The remote end hung up unexpectedly
22 silly fetchPackageMetaData Error: Command failed: git -c core.longpaths=true fetch -a origin
22 silly fetchPackageMetaData error: inflate: data stream error (unknown compression method)
22 silly fetchPackageMetaData error: unable to unpack a1d0fe355d809ba93f4ad4975d162a82fb91d423 header
22 silly fetchPackageMetaData error: inflate: data stream error (unknown compression method)
22 silly fetchPackageMetaData fatal: loose object a1d0fe355d809ba93f4ad4975d162a82fb91d423 (stored in ./objects/a1/d0fe355d809ba93f4ad4975d162a82fb91d423) is corrupt
22 silly fetchPackageMetaData fatal: The remote end hung up unexpectedly
22 silly fetchPackageMetaData
22 silly fetchPackageMetaData at ChildProcess.exithandler (child_process.js:204:12)
22 silly fetchPackageMetaData at emitTwo (events.js:106:13)
22 silly fetchPackageMetaData at ChildProcess.emit (events.js:191:7)
22 silly fetchPackageMetaData at maybeClose (internal/child_process.js:891:16)
22 silly fetchPackageMetaData at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
22 silly fetchPackageMetaData error for https://github.com/TheAppgineer/roon-extension-manager-updater.git { Error: Command failed: git -c core.longpaths=true fetch -a origin
22 silly fetchPackageMetaData error: inflate: data stream error (unknown compression method)
22 silly fetchPackageMetaData error: unable to unpack a1d0fe355d809ba93f4ad4975d162a82fb91d423 header
22 silly fetchPackageMetaData error: inflate: data stream error (unknown compression method)
22 silly fetchPackageMetaData fatal: loose object a1d0fe355d809ba93f4ad4975d162a82fb91d423 (stored in ./objects/a1/d0fe355d809ba93f4ad4975d162a82fb91d423) is corrupt
22 silly fetchPackageMetaData fatal: The remote end hung up unexpectedly
22 silly fetchPackageMetaData
22 silly fetchPackageMetaData at ChildProcess.exithandler (child_process.js:204:12)
22 silly fetchPackageMetaData at emitTwo (events.js:106:13)
22 silly fetchPackageMetaData at ChildProcess.emit (events.js:191:7)
22 silly fetchPackageMetaData at maybeClose (internal/child_process.js:891:16)
22 silly fetchPackageMetaData at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
22 silly fetchPackageMetaData killed: false,
22 silly fetchPackageMetaData code: 128,
22 silly fetchPackageMetaData signal: null,
22 silly fetchPackageMetaData cmd: ‘git -c core.longpaths=true fetch -a origin’ }
23 silly rollbackFailedOptional Starting
24 silly rollbackFailedOptional Finishing
25 silly runTopLevelLifecycles Finishing
26 silly install printInstalled
27 verbose stack Error: Command failed: git -c core.longpaths=true fetch -a origin
27 verbose stack error: inflate: data stream error (unknown compression method)
27 verbose stack error: unable to unpack a1d0fe355d809ba93f4ad4975d162a82fb91d423 header
27 verbose stack error: inflate: data stream error (unknown compression method)
27 verbose stack fatal: loose object a1d0fe355d809ba93f4ad4975d162a82fb91d423 (stored in ./objects/a1/d0fe355d809ba93f4ad4975d162a82fb91d423) is corrupt
27 verbose stack fatal: The remote end hung up unexpectedly
27 verbose stack
27 verbose stack at ChildProcess.exithandler (child_process.js:204:12)
27 verbose stack at emitTwo (events.js:106:13)
27 verbose stack at ChildProcess.emit (events.js:191:7)
27 verbose stack at maybeClose (internal/child_process.js:891:16)
27 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)
28 verbose cwd E:\Users\nicco\AppData\Local\Temp\7zS8894D5F0
29 error Windows_NT 6.1.7601
30 error argv “C:\Program Files\nodejs\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install” “-g” “https://github.com/TheAppgineer/roon-extension-manager-updater.git
31 error node v6.11.1
32 error npm v3.10.10
33 error code 128
34 error Command failed: git -c core.longpaths=true fetch -a origin
34 error error: inflate: data stream error (unknown compression method)
34 error error: unable to unpack a1d0fe355d809ba93f4ad4975d162a82fb91d423 header
34 error error: inflate: data stream error (unknown compression method)
34 error fatal: loose object a1d0fe355d809ba93f4ad4975d162a82fb91d423 (stored in ./objects/a1/d0fe355d809ba93f4ad4975d162a82fb91d423) is corrupt
34 error fatal: The remote end hung up unexpectedly
35 error If you need help, you may report this error at:
35 error https://github.com/npm/npm/issues
36 verbose exit [ 1, true ]


(Jan Koudijs) #15

Hi @Niccolo_Terzi,

Is git still installed? The issue seems git related.

In case you can’t get it up and running again, you might try a cleanup and reinstall.
I wrote uninstall/cleanup instructions on the project Wiki.


(Niccolò Terzi) #16

@Jan_Koudijs, thanks for the reply.
yes, git and nodes were still installed.
i followed the uninstall procedure now, everything ok.
but trying to install the extension manager gives the same error.


(Niccolò Terzi) #17

this is the new log. (copied starting from the errors section, and only the first part). is there any place where i can ask for assistance?

141 silly tryHTTPS attempting to clone git+https://github.com/roonlabs/node-roon-api-settings.git
142 silly tryClone cloning roonlabs/node-roon-api-settings via git+https://github.com/roonlabs/node-roon-api-settings.git
143 verbose tryClone git-https-github-com-roonlabs-node-roon-api-settings-git-36da6a4c not in flight; caching
144 verbose correctMkdir C:\Users\nicco\AppData\Roaming\npm-cache_git-remotes correctMkdir not in flight; initializing
145 info git [ ‘clone’,
145 info git ‘–template=C:\Users\nicco\AppData\Roaming\npm-cache\_git-remotes\_templates’,
145 info git ‘–mirror’,
145 info git ‘https://github.com/roonlabs/node-roon-api-status.git’,
145 info git ‘C:\Users\nicco\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-roonlabs-node-roon-api-status-git-4047c0f4’ ]
146 info git [ ‘clone’,
146 info git ‘–template=C:\Users\nicco\AppData\Roaming\npm-cache\_git-remotes\_templates’,
146 info git ‘–mirror’,
146 info git ‘https://github.com/theappgineer/node-api-time-input.git’,
146 info git ‘C:\Users\nicco\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-theappgineer-node-api-time-input-git-b7e616c8’ ]
147 info git [ ‘clone’,
147 info git ‘–template=C:\Users\nicco\AppData\Roaming\npm-cache\_git-remotes\_templates’,
147 info git ‘–mirror’,
147 info git ‘https://github.com/roonlabs/node-roon-api-settings.git’,
147 info git ‘C:\Users\nicco\AppData\Roaming\npm-cache\_git-remotes\git-https-github-com-roonlabs-node-roon-api-settings-git-36da6a4c’ ]
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/dev does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/master does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.2 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.3 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.4.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.5.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.5.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.6.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.6.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/dev does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/master does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.2 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.3 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.4.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.5.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.5.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.6.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.6.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/dev does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/master does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.2 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.3.3 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.4.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.5.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.5.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.6.0 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/tags/v0.6.1 does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: refs/heads/dev does not point to a valid object!
148 error git fetch -a origin (git://github.com/theappgineer/node-api-extension-installer.git) error: wrong index v1 file size in ./objects/pack/pack-12ecae85466e5de8a0c705f707726fe9273f50a6.idx


(Jan Koudijs) #18

Please try npm on its own by issuing the following command in a command window:

npm install -g https://github.com/TheAppgineer/roon-extension-manager.git

Does this work?

If not, then something is wrong with the npm installation. You might try to repeat the cleanup and then also clear the npm-cache by deleting the folder with this name in the %appdata% folder.


(Niccolò Terzi) #19

Yes, the command npm gave the same error.
i cancelled the npm-cache folder and the new install was perfect!
thanks a lot :slight_smile:


(Jan Koudijs) #20

Good, I will add the ‘cache clear’ step to the uninstall instructions.