HQ Player and MQA

I have just got a new DAC, a Mytek Brooklyn. I am trying to play an MQA file through Roon to HQ Player but I cannot get the DAC MQA light to come on. It just plays as a 44.1 FLAC. Even I turn off all filters and dithering in HQ Player It still doesn’t work.
Are there any settings in HQ Player that will enable the DAC to see an MQA file?
Thanks.

Hi Ian…

If I had to wager a guess, your HQPlayer digital volume control is not set to 0 dB – as that is not advised for general upsampling use. But check that setting. Any digital gain other than 0 dB will cause a recalculation of the data and destroy any in band coding, such as MQA. I do not use MQA, but I can verify that DTS encoded PCM will pass through HQPlayer successfully only if all filters and dither are disabled and digital volume is set to 0 dB.

AJ

Thanks for that Andrew. Yes my volume is set to -3 which I was trying as I had read that was best when upsampling? I’ll try 0db later and let you know if it works.

Ian

As you are finding out, Ian, unless/until MQA wisely allows software decoding closer to the source, rather than at the sink, MQA will be impractical to decode in many modern systems. Any upstream digital processing, including simple volume control, wipes out MQA encoding.

AJ

That’s the thing with MQA the file must be un modified to light the light. This way you know you are getting the real deal.

Yes it was due to the volume set to -3. When I set back to zero I am able to play MAQ and the DAC lights up. I need to turn off room correction as well.

I was wondering if in the future if HQ Player could detect an MQA stream and automatically turn everything off, I don’t mean decode it, just detect it?

Yes, agreed that an encoded PCM passthrough setting in HQPlayer would be useful. However, I doubt that it will be implemented.

AJ

@jussi_laako My default SDM filter is poly-sinc-short-mp. Default noise shaping/dither is ASDM7.

The default settings play TIDAL MQA files from Roon without any problems. But today, I decided to try one of the MQA-optimized filters, so I selected poly-sinc-mqa-mp. I tried to play a TIDAL MQA file from Roon and the playback never started. So I switched to poly-sinc-mqa-mp>NS5>Auto>PCM and the TIDAL file in Roon played without any problems (my DAC supports PCM up to 384kHz and that’s what HQPlayer chose).

For the time when I tried to apply the poly-sinc-mqa-mp filter to SDM playback and failed, the log file has multiple entries of this line:
2017/01/13 21:38:21 No suitable output rate for 48000, stop

Is there a genuine problem here, or was the filter never designed for SDM use?

Thanks,
Jeff

1 Like

This happens if your DAC/driver doesn’t support 48k-base DSD rates. MQA-filters have a constraint that only simple integer ratios can be done.

So the success for the 48/96/192k input rates with those filters depend on the particular DAC and driver. For example iFi DACs can do also 48k-base DSD rates just fine, but their ASIO driver on Windows supports only 44.1k-base DSD rates.

That is indeed the case with my DAC (Oppo HA-2).

Thanks, Jussi!

EDIT: Just to close the loop here – all of my 24/44.1 MQA TIDAL streams play properly on my DAC with the HQPlayer MQA filters.

hello i just spent two hours i wont get back trying to solve my own mqa issues .
here is my findings
in hq player i choose 24 bit , no filters , max bit rate 384 .
in roon no mqa support .
this lets my dacs mqa light up . any other ways does not .
in the roon playback tree it does show mqa up to 96 , but this is not my dac its software i feel .
only when i did as above can the mqa show on display .
just what i see , even though roon tree shows hq pcm 48 dac shows mqa 96
the display of the dac shows to me whats really playing .
the files 2L THE MQA EXPERIENCE is as follows . flac 44.1 24 bit - MQA352.8
the tree only shows pcm 44.1 dac shows as above . this mqa and hq player is nuts , thank god i dont upsample . now my issue is if not playing mqa what then . i do sue some filters and dither

Which DAC?

1 Like

You get best results with MQA by letting Roon decode it and upsample it with HQPlayer’s filters to your DAC’s max rate.

When your DAC decodes MQA, it does same thing as Roon and then upsamples it with MQA’s poor quality filters.

I think the folks at MQA would dispute that statement…

2 Likes

Sure, you can download the filters from internet and check the responses yourself and make your mind what do you think.

1 Like

the best mqa is turn off all filters in hq and 0 vol. but thuis can have issues if you over drive the dac input .
if we can lower the vol in tidal thuis works far better .

hello how are you , longtime no posting to you . as much as your software still sounds best i wish you could make a better gui to play with it lol .

toppings new dac . got it sorted out now sounds great .

Certainly not! Let Roon decode and let HQPlayer upsample to format most suitable for your DAC with filter of your choice. Not one of the poor leaky MQA filters, that can anyway operate to max 8x PCM rates! poly-sinc-mqa/mp3 and poly-sinc-gauss-hires are good filter starting point.

In any case, lossy MQA compression is best avoided and better go with real hires.

What’s wrong with HQPlayer Client?

1 Like

the purpose is to leave any decoding to the dacs . i cant see why there are two camps mqa and non mqa . i can say not all dacs decode well and ur correct in some cases better to do as advised. but this is a case by case . i aslo can agree upsamplig some content sounds better. but again, mostly not the case for all . horns can blare and im sure if i spend a few hours to find a good filter setting to stop makes it good. but then the rest might be bad lol . hq player is far and away the best player but the endless combo settings make it impossible for me to use in its entirety complex state. again, yes, the best we have to date by my ears .