HQ Player config on Roon

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro with Audiophile optimizer
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Cox Gigablast, Orbi, Netgear

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ultra rendu, Hugo 2, HQ player

Description Of Issue

I am trying to add HQ player (evaluation), keep getting error message from Roon “couldn;t $ HQ player”. The hqplayer 4.0.2. and Roon core are running on the same machine.

Things I have tried -

  1. Followed the instructions and added as Local Host - (i) install HQ player (ii) enable NAA on Ultrarendu (iii) Add hq player on Roon as local host
  2. Tried uninstalling and reinstalling HQ player, restart Ultrarendu, restart the entire network, run optimizer again…still no luck.

Please advice.

Hi @Ravi_Narayanaswamy,

Can you double check that you used these instructions to set HQPlayer up?

You need to go into HQPlayer and enable the “Allow control from network” feature:

– Noris

I tried both enabling and disabling it because hqplayer is on the same machine Roon core is running.

The path Roon - ultrarendu - Hugo 2 is working perfectly fine. The only issue is when I try to add hqplayer and NAA on ultrarendu. The hqplayer output setting is network audio adapter - ultrarendu and it is recognized, Input settings I tried WASAPI and none.


Hi @Ravi_Narayanaswamy,

Does HQ Player work by itself without Roon in the mix? What if you try adding the current IP address of your Core to the HQ Player setup in Roon, does that change anything?

– Noris

Hi Noris,

The hqplayer plays fine through ultrarendu-hugo2 chain, however, there is some dither/noise when upsampled. When tried to play through Roon I added the IP address obtained through
Ipconfig, but still the same error message.

Quick related question- i predominantly hear through headphones audeze lcdi4 through ultrarendu-Hugo 2 chain, does Roon suggest using hqplayer or keeping it loseless direct?

I am trying to determine if all this effort is worth the time.

Thank you,


Hi @Ravi_Narayanaswamy,

Is the noise occurring when you are using HQPlayer directly, without Roon in the mix at all? If so this would suggest that it is a configuration on HQPlayer itself and not necessarily related to Roon.

If you are able to use Roon lossless without HQPlayer you can certainly do so. The main benefits of HQPlayer are to lessen the strain on the DAC by moving the upsampling portion away from the devices internal DAC and onto a more powerful machine (see this thread for a great read: What do most people use HQ player for?)

As for HQPlayer not connecting, are you perhaps using an antivirus application or a firewall blocking tool on that machine? If so, I would check to see if there is any change in behavior if you temporarily disable this firewall. I would also make sure that Roon.exe, RAATServer.exe and HQPlayer have been properly added to your Windows 10 firewall. You can use these instructions to check this aspect.

Please let me know if this helps!

– Noris

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.