HQ Player on Mac - different to HQP Embedded


(Sean) #1

Hi jussi

While you’re hard at work helping Andrew (and me) with getting HQP Embedded to work at DSD512 on dad’s sonicTransporter i7 running RoonServer on the same machine, I thought I’d try HQP on my Mac i7, evaluation version to begin with. Dad insists I need to HQP, based on SQ he was hearing (using DSD512 with the 2-box solution that we got working flawlessly, before the latest update). Even though I was insisting he try HQP, I’d never tried it myself till now !

So I’ve gotten to know the Config page of HQP Embedded quite well these past few days.

So when I loaded the Mac version I went to look for ‘output mode’, to force all up-sampling to either PCM or DSD, but I can’t see the option (see attached)?

Also with HQP Embedded, when looking at the Roon Signal Path, it would show the exact filter that HQP was using but with my Mac version it just shows auto and PCM (see attached).

Endpoint is microRendu.

It’s working, DAC is showing PCM705kHz and PCM768kHz sample rates and sound is coming through.

I’m probably missing something very obvious.

Cheers!


(Sean) #2

Solved it. Silly me.

In HQP Embedded it’s all in one screen - in the Config screen.

But on the Mac I missed the ‘output mode’ on the main window

@jussi_laako , even though I’m using my Chord DAC’s internal digital volume control (always much lower than -3db) I should leave max volume of HQP at -3dB? I don’t understand the reason.

The max volume I reach on my Chord DAC is -30dB, so risk of clipping should be zero right? Or is there a different reason to keep HQP’s max volume at -3dB?

And is there a way to set fixed volume on the Mac version?

While your tap length number/calc is probably different to Rob’s method, I have to ask how many taps with your PCM pol-sinc-xtr filter? :grin: I know the taps number is meaningless without context but I’m still curious.

HQP sounds great by the way!

Hopefully we can get DSD512 working on my old man’s sonicT i7 in time.

Cheers!


(Jussi Laako (Signalyst)) #3

Because of possible inter-sample overs in the upsampling filters. This happens especially when source data contains digital clipping and the clipped peak is then partially recovered. Recent RedBook/Tidal material certainly tends to contain lot of digital clipping, thanks to loudness wars!

Data path between HQPlayer and a DAC has limited value range. 0 dBFS representing highest sample value possible. If you set volume control in HQPlayer higher than -3 dBFS, it is likely that values exceeding 0 dBFS are encountered. This is not a problem for HQPlayer’s internal data path which practically cannot clip, but it cannot be represented to the DAC using the available value range, so it would clip when producing output values. To prevent nasty clipping, HQPlayer is monitoring output and has soft-knee limiter which is triggered when such values are encountered. This causes the “Limited” counter in HQPlayer main window to increase and also volume knob changes to red to indicate “turn down the volume!”. But it is best to avoid this limiting to kick in by keeping volume set to lot enough value that there’s enough digital headroom in the output sample value range.

There’s certainly material where even -3 dBFS setting is not enough, but for most content it is enough.

Chord’s volume control cannot solve running out of sample value range before the DAC…

There’s no fixed number of taps, because there’s no fixed conversion ratio, number of taps depends for example on conversion ratio. But for example if you go form RedBook to DSD512 using closed-form, you have about 8 million taps.


(Sean) #4

Thanks Jussi!


(Sean) #5

Now it makes sense. Rob’s 1st filter stage takes care of this (2.75dB headroom) but if you up-sample to 705/768kHz you are effectively by-passing this 1st filter stage’s headroom management.

https://www.head-fi.org/threads/chord-electronics-hugo-2-the-official-thread.831345/page-778#post-14116607


(Nick Tomlinson) #6

Hi

I am using Roon and HQ Player and have the same signal path display as the first Roon screenshot, ie Default, Default, PCM, 176.4KHZ.

I cannot figure out how to get HQ Player to pass the filters to Roon to display or alternatively how to get Roon to display the filters passed by HQ player.

Anything obvious?

Thanks

Nick


(Sean) #7

Hi Nick, see the second post, where I had to change the output mode for Roon signal path to show the HQP filter used.

Have you tried that?


(Nick Tomlinson) #8

Hi Sean

I don’t see where to change output mode in the signal path or Roon preferences? I think I am missing a step.

Thanks

Nick


(Sean) #9

Hi Nick, did you see the 2nd post above? Screenshot there - you’ll see output mode in HQP.

Change from Auto to PCM or SDM (in HQP).


(Nick Tomlinson) #10

Sean

Got it, thanks a lot.

Working perfectly now.

Nick