HQ Player - Roon Troubleshooting Guide

Since there are a number of users (including me) who are using HQplayer with Roon, it would be nice to have a troubleshooting guide as a sticky. I have been using HQplayer for about 3 months and Roon + HQplayer for about 2 months. I have come across a range of issues each requiring a different solution. Both Roon forum and CA forum has been very helpful, but it requires a lot of asking and searching. I am listing the issues I faced and how I solved them, YMMV.

As a first step, see if the settings you want work with just HQplayer, without Roon or NAA. Then add NAA and finally add Roon. This would help to isolate the source of the problem.

I am running both Roon Core and HQplayer on MBP 2014, i7 2.5GHz, 16G RAM, Yosimite -> NAA (Audiolinux) ->iFi iDSD or Hugo TT

  1. HQplayer goes to sleep: Symptom: Playback halts usually in a few minutes, but starts when you bring HQplayer to the foreground or in focus. This has nothing to do with Roon, it is a energy/perfomance optimization ‘feature’ of Yosemite (don’t know about El Captain). Proof: Keep activity monitor in the foreground, when the playback stops look at the Energy tab and App nap column for HQplayer would say Yes. Solution: Disable App nap for HQplayer. However, you cannot right click and use the checkbox option as HQplayer does not have this feature exposed. Instead you can open terminal and disable App nap. You can either do a system wide disable of App nap (I would not recommend it unless the Mac is used purely for music playback). You could disable App nap for HQplayer alone using the following command: defaults write -app HQPlayerDesktop NSAppSleepDisabled -bool YES.
  2. Playback stutters: Symptom: Playback stutters, stops/starts and may sound scratchy. More likely to occur when using poly-sinc filters of HQplayer or if using some of the filters that need a lot of resource (Ex: closed-form without CUDA). Solution: Try switching to less resource intensive filters or lower rate. poly-sinc-2s-* works well or use closed-form with CUDA if available. Another solution (that worked for me) is when using poly-sinc, uncheck both cuda and pipeline SDM, then restart HQplayer. This is counter-intutive, but it worked.
  3. Playback drops: Symptom: Playback drops but it continues without the need to do anything, generally not scratchy or noisy, music does not come to a halt. Solution: This is very likely either a buffer issue or a network issue. If you are using ASIO drivers, make sure you increase the buffer time to 100 or 250 ms in HQPlayer settings. This could also be a network issue. If on wireless network, try to switch to the band (on a dual band router) or try a different channel. While a poor network connection may not be obvious during browsing, it is very audible when trying to play DSD or DXD. The drop-outs went away for me once I switched to a different band or when I used the Thuderbolt-Ethernet adapter to make it hard-wired on my Mac.
  4. DSD plays only noise: If you have a DoP only DAC/driver, make sure '‘SDM pack’ is set to 'DoP in HQPlayer settings.
  5. DSD64 does not upconvert: Check if file->DSDIFF/DSF->DirectSDM is unchecked.

Sorry in advance for the long post. I hope it saves someone a lot of time.

3 Likes

Thanks KMan, very useful post.

I will try to keep this thread for fixes. People experiencing an unfixed issue, please make a new thread in Support, or post in one of the Build issue threads in this section. Anyone who finds a fix for an issue please feel free to post it below.

Further useful troubleshooting and setup resources are:

How do I use Roon and HQ Player together FAQ

Geoffrey Armstrong’s HQ Player Kick-Start Guide

4 Likes

Thanks @andybob, moving unfixed issues to its original thread.

NAA missing after using another source
After listening to another digital source HQP produces a “device not configured” message and an NAA does not appear in the Device dropdown list.

This can occur when the NAA is connected by USB to a DAC and the DAC does not have the USB input selected. Select the USB input on the DAC and the NAA will reappear in HQP. Best practice is to change the DAC input to USB before changing the Roon zone to HQP.

Non localhost HQP installation not working
Check that the “Allow Network control” button is pressed on the HQP toolbar.

2 posts were split to a new topic: CUDA just for Nvidia?

A post was merged into an existing topic: CUDA just for Nvidia?

A post was split to a new topic: Restarting USB and NAA