HQ player-what a colossal Pain!

Why offer an option where you have to set it up in such a way?


If you have a suggestion for feature enhancements, send a post to Feature Requests with specific ideas or use cases.

If you have a meaningful question, please include enough information that someone here can help you.

I failed in checking my frustration
Would be nice from time to time with Roon to just be able to select something without a covoluted 10 step process…its 2019 after all

1 Like

Meaningful question:
Despite following instructions i cannot get anything to play with the HQ player

1 Like

There is no question that HQP is not an easy to use program. The learning curve is fairly steep and it requires some experimentation to get it right for a given system. This is well known and I suggest that you consult the Audiophile Style (formerly Computer Audiophile) forums for advice and knowledge on HQP. It is not a Roon issue. They just make it possible to connect to HQP but they do not own it or have any control over how it is setup.

If you are not interested in putting in the work, then you can accomplish some of what HQP does directly within Roon. That said, when HQP is properly setup and tuned to the equipment in a system, the results can be amazing.

DSP like HQP does is not inherently easy and it is possible to get a worse outcome than a direct connection to Roon RAAT if one is not careful.

Take some time and do the homework and you will be happy with the results.


I second that, it can be like looking down a very dark hole with HQ player initially but the rewards are great if you persevere.

1 Like

Hi Thomas

How far have you gotten and what’s your complete chain (including network configuration)?

Always helps if you can include screenshots of all your settings.

It can be hard to guess what’s wrong and help you out without any info.


1 Like

The first step is to get some sound out of HQ Player by itself. The Kick Start Guide is a useful resource for this.

After you have HQ Player working, then this KB article sets out how to set it up with Roon as a front end.

If you get stuck, ask a question here.

1 Like

Ive set it up.
it appears as a zone to choose.
put ip address in as instructed.
when i attempt to play something a nitration is dispalyed as to which track will be played with a thumbs up or down next to it…but nothing ever starts playing.

IMAC as controller.

NUC with Rock connected to router.

Bang and olufsen A9 connected to router.

use a NAS for my music files.

Can you show a screenshot what you have configured as output to HQPlayer?

After sound leaves Roon to HQPlayer, it is handled by HQPlayer from there on, just like any other source to HQPlayer. So Roon doesn’t have control over where and how it goes from there, it is now in HQPlayer’s domain.

1 Like

happy to…but unsure where to find

expect you are looking for more than this photo


Initially I had issue, whats your setup on the HQ player app itself? Try these basic settings

I cant even get to that point.
Have never seen that layout nor do i know how to find it

Ok got it…working on it

Will post next roadblock shortly

Thats good to know, Ive setup Fidelizer Pro + HQplayer + Jplay Femto and its working beautifully. Using a vintage DAC too and results are just jaw dropping

I mirrored your settings from the picture but still no go.

What should device be set for?

Currently on default

It’s not clear where HQP is running or if there is a NAA endpoint device. It appears from his description that he is trying to go directly to the DAC.

1 Like

Get HQPlayer running and playing music first. Then turn on network control in HQplayer and connect Roon to it.

Ok cool…big step…got it playing on the desktop player.

Not have luck getting it to Roon


Is HQPlayer on the same machine as Roon? If not have you enabled network control?

The network control button is the one on the far right in the picture in this post: