HQP and not HQP related - upsampling

It only gives me the choice of 64 or 128. Have always had it set to DoP. I also have Integer mode enabled nut no idea if I should or not. I don’t know what it is except that Audio Midi calls each number setting integer.

I also don’t know what channel mapping is. I take it that down mixing when needed means to down sample? Now I’ve written it it doesn’t sound right. So I guess I don’t know what that means either. I think I was assuming it meant down mixing from 7channels to 2 or something.

Dirk,

Thank you kindly. I thin k this is a very wise response and I shall follow it.

colin

Okay, it seems I made a mistake. I have been fiddling all evening. I played various different ways of playing the same piano sonatas for John. He was not happy with any of them until I played thru HQP at DSD 128 although he was happy with DSD64 and the unaltered 44.1khz tho he preferred the DSD’s. Even I could hear the bum high n notes on the piano. Set my teeth on edge.

Why the screen shot? Well, the DAC is supposed to play DSD 256. Look what HQP does at the last hurdle. I don’t understand that at all. I can’t even get that far directly thru Roon as it doesn’t give me a 256 option.

Any ideas?

Thank you kindly.
Colin

It looks like you are upsampling in both Roon and HQP. You should only do upsampling in one of them.

If you want to listen to DSD 256 upsampled in HQP only then:

  • disable sample rate conversion in the Roon DSP Engine; and
  • set the HQP Settings/SDM Defaults/Bit rate to 44.1k x 256.

You also have the Roon Parametric EQ enabled. If you did not intend to use the Parametric EQ then you could disable everything in Roon DSP. Otherwise you can use Parametric EQ in Roon and upsample in HQP.

If you are using HQPlayer with Roon, it is best to turn off Roon’s DSP for the HQPlayer zone completely, so that it doesn’t accidentally end up doing something.

A post was merged into an existing topic: Setting up HQPlayer within Roon

Jussi and Andy-I was unaware that Roon settings were in play when using HQP.

So I disable all filters in Roon before I play with HQP?

By my mistake I meant giving hearing tests to John using both programs because he prefers HQP which means I will probably have to buy it now!

You have probably figured out we are in our retirement years now. We spent a fortune on our gear. And yes I know i could have spent more. In fact I did spend more because I was taken in b y the first audiophile place I went to and spent many 0000’s on stuff I didn’t like. They didn’t match and some were just not worth it. Like the Arcam AVR400 was a waste of money. I changed that first. In the end everything was changed. So I lost a lot of dosh on trading in. My biggest regret is letting my Oppo 205 go. I did this soon after the first trauma in 14 so wasn’t really aware of what I was doing. I don’t seriously think I am missing anything. It’s just the cost to replace now I am not willing to spend. Plus I still have a modded 105. Someone said I can record SACD using it and a program I can 't recall if that was on this forum or not. Besides do I really need to? I can play the discs.

I believe the new Yamaha, an upgrade on the RX_A3080 is out later this year but I will only replace if the upgrade is sound and not just smart stuff.

I just disabled everything in Roon but got the same playback result using HQP.

When DSP roon presets are disabled it should look like this.
I’m a HQp embedded user.

Okay having really studied the picture I get on my system, I notice it says the settings are those Roon puts on when I make adjustments.

So how do I make adjustments using just HQP? Like using HQP for the equalizers and upsampling?

Also as the sound of violins and piano is better, even to my ears, when played through HQP and using the setting, the upsampling and Parametric Eq., which I now realise is still Roon settings, how can this be? It is NOT our imaginations. The high notes on the Piano and the Violin set my teeth on edge when played just thru Roon via the 8300cdq. Yet is lovely and smooth when using the HQP plug in but with what I now realise are still Roon doing the upsampling and Eq.(Tho the info given doesn’t say that-in the photo of the signal processing. The two pics are very different. Plus it gives me more options than Roon.)

I am confused and maybe what I have just written is confusing too.

I am thinking I am supposed to set up the EQ and upsampling within HQP Desktop4 before it is ‘plugged in’. That doesn’t seem right to me.

Mind you, I can’t play anything thru Desktop4. I have managed to get it to list my whole library but it refuses to play anything. I was hoping to get an idea of how it sounded without going thru Roon.

The sound difference is such using HQP plugin thru Roon that when I told my husband the cost of it his response was ‘well, if it makes my music sound like that, it’s worth it.’ He is a Geordie and not free with his money (unless he is spending it on me. I don’t complain.) So i was very surprised at his response and it also is enormous praise from him for the HQP thru Roon. He doesn’t praise easily and he is a professionally trained Opera singer/pianist though he followed his parents advice and got a ‘proper job’ and is a world renowned historian instead! (In a specialised field so it is unlikely you will know of him unless you have an interest in the same field.)

I am trying to say that despite the sound advice(pun not intended) from Dirk, I am going to have to buy this HQP because John’s comment is remarkable so I can hardly ignore it.

I just want to understand how the bl**dy thing works first.

And to think I started out not wanting to commit to Roon and wanting you ,lot to explain to me why I ought to and I have done it all on my own. I still think the Eq are too hard and could be simpler as it assumes the user has in depth audio/studio equipment knowledge. I just got the sound I liked by chance and saved it. If I lose it, I doubt I could find the same adjustment again . I also can’;t understand why on earth one cannot adjust the EQ whilst listening. That makes no sense.

I also said I wasn’t interested in the opinions of others about my records but in fact have learned a lot by reading the info because they are not just reviews.

It turns out I love Roon despite not understanding it properly and from some of the explanations I doubt I ever will because it is a foreign language to me.

Upsampling in both Roon and HQP doesn’t make any sense. So you should definitely disable Sample Rate Conversion in Roon if you want to upsample with HQP.

HQP doesn’t have built in EQ. If you want to use Roon’s Parametric EQ and upsample in HQP then you can. Some people might prefer a signal that doesn’t have EQ, but it is up to you. You can enable or disable Roon PEQ as you prefer.

To make adjustments to upsampling in HQP you alter the parameters in HQP Settings. Since your DAC says it will accept DSD 256 you can select 44.1 k x 256 in SDM Defaults/Bit Rate. That determines the default output rate from HQP.

In HQP Settings, try SDM Pack/DoP. If that doesn’t work, change it to None. If neither work, then check back here.

The Roon DSP Engine, including PEQ, and HQP are complex. You don’t have to use either of them if you just want to listen to music. If you do want to use them, then there is some complexity. Jumping in the deep end of the swimming pool means deep water.

Edit: I should say for completeness that HQP can process external EQ through a feature known as convolution. This is more complex than anything we have been discussing. It is too complex for me to use to tweak EQ. When I want to use EQ I use the Roon PEQ and upsample in HQP.

When you write about making adjustments in Roon and in HQP do you mean adjusting HQP within Roon? Or within Desktop 4?

Don’t ask me how but I have both Desktop and Client up and running and converting to DSD, without Roon.

HQP is set as you suggest, 44.1k x 256. The HQP client reads that it is sending 5.6 and that is what my DAC reads too. I cannot recall right now whether this is 256 or 128. If it is not 256, I will try again to get thru to Audiolab support tomorrow. I was too late today.

Thank you kindly for your patience and support.

Make adjustments to Roon DSP in the Roon DSP Engine.

Once Roon is setup for HQP for your device (as it is) then you don’t need to further adjust Roon/Device Settings.

Make adjustments to HQP Settings in HQP Desktop.

If Sample Rate Conversion is turned off in Roon, your DAC is reporting that it is receiving DSD 256 and you can hear music then we are there ! Congratulations :grinning:.

I don’t think we are there. I wrote that my DAC and HQP Client were reporting DSD output of 5.6. If it’s 256 should it not be 11.2 or 11 something?

Yes. DSD 128 is 5.6MHz. DSD 256 is 11.2 MHz.

What setting are you using in HQP Desktop Settings/SDM Default/Bit Rate ?

I looked and either I am tired or just can’t decipher what you have asked.

I chose 44.1 x 256. The Client shows 11.2 but nothing will play.

When I choose 44.1k x 128 it plays. Very well I might add. I also realise I do not need EQ. It’s best to listen to the album as is. Stupidly, I was wanting to use as many features as possible since it cost so much!

However, the upsampling is a BIG plus with both programs. I guess I shall either use HQP as is or as I can thru Roon until I decide what to do when my year’s rental of Roon is up.

Why is it beneficial to use both?

It just occurred to me to take a file and make a DSD256 copy of it and see if it plays. If it doesn’t then the DAC is the problem OR could it be the MBP? Maybe it’s audio card or whatever it is won’t process 256?
It just seems unlikely that the DAC is at fault.

OK.

What setting are you using in HQP Desktop Settings for SDM Pack ? If it says "none’ try changing it to ‘DoP’ and see if that works or vice versa.

If changing SDM Pack doesn’t work, take a screenshot of your HQP Desktop Settings and post it here and we’ll see if we can find a problem.

You could try and play a DSD 256 file to check your DAC, but I’m not sure how to create such a file or if anyone sells DSD 256 files for download.

Do you have oversampling turned on in your DAC ? If you are upsampling in HQP then your DAC can be set to non-oversampling or some other neutral setting. If there is no control to that effect then don’t worry about it.

I’m not going to try and talk you into using HQP. I use it because I prefer the sound on my system using the filters and modulators in HQP over those provided in Roon. You must listen to HQP and to Roon without HQP and make up your own mind.

Yes that is the conclusion my husband came to. I already thought so but needed blind tester. He much preferred the HQP sound and when I told him the cost of it he said ‘well if it can make my music sound like that it is worth every penny’. Literally. And he rarely praises anything. I was shocked. Really. I thought I knew what he would say when I told him the price. I was completely wrong. I did notice he had ‘gone’ when he was listening so I knew he liked it. Even I could tell the violin and piano highs didn’t set my teeth on edge. and listening to Carly earlier, upsampled also to DSD 128, the sound was amazing, so clear, and no need at all for EQ.

I think there is something not right with my DAC. Even Audirvana rejects 256 and plys it at PCM 384. Media Centre crashes within seconds of starting to play a 256 file.

Oh, yes, I converted a whole album to DSD256, and Roon downgraded it to 128.

I asked a question earlier but can’t recall if it was in this thread. The answer I got was not the answer to my question as I clearly didn’t word it correctly.

I asked if instead of using the MBP internal 1TB SSD drive to store my library, and get Roon to play from the external drive, would this wear out the external drive more quickly than using the internal drive? I do have several fast, Thunderbolt 3 drives which will work well as they are really fast, copied my 500gb music folder in 4mins. I also keep a copy of the music folder and my photography on the NAS and the photos on one other drive. So I have my muisc folders on at least 5 drives. Can you tell I lost my only back up once?

1 Like

Did you try changing SDM Pack in HQP Desktop Settings to see if that made a difference to your DAC playing DSD 256 ?

If that doesn’t make a difference, then you should check with the DAC manufacturer as to what more is required to play DSD 256.

Assuming your external Thunderbolt drives are SSD you shouldn’t be worried about wearing them out with read operations. SSD reliability is expressed in number of writes. Reads have such little effect on SSD durability that they don’t bother mentioning it. This is great for audio which is an archetypal write once read many usage.

Yes, if DoP is not on, then it won’t play DSD at all. It plays DSD128 or 64 nd it will downmix to 128 from 256.

I am awaiting some info from Audiolab regarding this. It’s several different players this is happening with. Most report that it only does up to 384khz PCM and up to DSD 128.

1 Like

It is pretty straightforward to setup parametric EQ in RoomEq Wizard and export the impulse response as WAV for convolution…