HQP and Soekris 2541 DAC?

Hi there,
I have my Roon core on a MacMiniM1 and a RPi4 with RoopieeXL with NAA activated and used in the past with a Topping D70 DAC.
I switched to a Soekris 2541connected it to the RPi4 via USB and HQP could see the Soekris.

But I cannot listen to music I get this error message „broken pipe“

Are there any specific settings for the Soekris?

P.S. Set-up without HQP works as it should.

Do not know how exactly I made it, but now it is working. :slight_smile:

1 Like

Now as the DAC is working, any recommendations for Filter settings?
(the 96kHz were only for testing purpose)
Highest PCM or DSD256?

Not working again. Same, as I do not know why it worked I do not know why did not work today.

“Push to FIFO failed”

Usually I disconnect all components from power and turn everything back on, when I want to use it.

There seems to be some kind of miscommunication between the Soekris 2541 and HQP which by chance sometimes starts to work….

P.S. and also, as soon as I switch to RAAT everything works, so it seems not to be something in my setting, it seems something between the 2541 and HQP which needs some convincing to work together.

Have you tried to directly connect to the computer that runs HQP?
I do not have any experience with Pi
Did you disable the Pi from roon?

I’m using a zen stream to a dac and direct usb from core to the second dac. Sometimes (not tested enough) if I restart the mini Roon Core that also has HQP I can play from roon, HQP looks like getting the audio but no sound and the progress bar in roon it doesn’t move. I just have to reselect the NAA (zen stream usb) from HQP prefs and works again.

1 Like

It worked again when I switched back in RoopieeXL from RAAT to NAA.

Strange and very inconvenient when this always happens when I turn of the power.
Never was an issue before with topping D70 after complete power of always went back to normal when I switched back on power.

and biggest question where is the problem located? DAC? HQP? RPi4/RoopieeXL? Roon?

I should say in Roon. You should delete/disable the Roon “room” configuration for RAAT/RoPieeeXL .
If you have that configuration active while Roon-HQPlayer-RoPieeeXL/NAA is active too you’ll have a conflict between the different configurations


Thanks I did that.

Next observation: When everything is working correctly, I can turn off the DAC and back on and HQP can again still play to the DAC. So most likely rules out the DAC.

Edit 1:
Same goes for turning of the DAC and the RPi4. Pointing more and more in the direction of Roon.

Yes, it does. If you shutdown the dac, when you power on it back you should restart for first NAA and then HQPlayer


Now after disabling the RAAT / Soekris DAC 2541 device HPQ always works after shut down.

1 Like

okay, maybe I was a bit too drastic…

1 Like

All fine, thanks Stefano. :slight_smile:

1 Like

It is still unfortunately completely „plug and play“.
I think I have to figure out the correct „turn on“ order and/or reboot sequence. Simply firing everything up end up in „no music“ and wild turning on and off everything and restarting HQP etc.
But I will figure it out. :wink:

Actual HQP settings:

Other suggestions?

May be I should start moving convolution to HQP? Have not yet looked into it. :wink:

First - dac
Second - NAA
Third - HQPlayer
Fourth - Roon
… and wait for a complete boot before going to the next step


Annoying but I had to learn that order, it did just work so now I just use it.

In using HQPlayer I would disable all DSPs in Roon. So in your case:

  • no resampling in Roon
  • no convolver in Roon

How to handle this in HQP:

1 Like

True, I did not notice that. Just use the matrix in the HQP.

Just for my reputation. :smiley:
Resampling is activated, but all settings are on “default”, so no resampling happens. :wink:
Yeah, I know I could also deactivate it. :smile:

Edit: I have read the thread and I do not understand very much what they are talking about…

First, to me it looks way less convenient to use convolution in HQP compared to Roon. So I hope it is really worth doing it in HQP.
Second, I need an answer to a fairly basic question, which wav files from oratory I use, the 44.1 or 48 kHz files?

1 Like

Oratory? None, if you are using AutoEq, choose the parametric EQ txt file and load that one to the matrix processor instead of convolution. It is sampling rate agnostic, since it contains just the filter parameters. And it is much lighter to process.

1 Like

Thanks Jussi, now I know what Traian was talking about. :slight_smile:
Will check it out.
I always thought PEQ is somehow „less precise“ compared to convolution. So for which case it makes sense to use convolution?

Another question, can I add filters in the txt file or do I need to adhere to the given format? as I use sometimes in Roon convolution + an additional PEQ filter (e.g. extra Bass shelf filter).