HQP streaming does not input to DAC

Hello, HQP + Roon enable me to still use (to the full extent) my already old and PCM only capable DAC M2Tech Young (1st generation), also in Windows 10 most recent April 2018 update. The version of Roon is as well the last 1.5 build. HQP is 3.20.4. I’m running both HQP and Roon on same computer, feeding my DAC thru USB (I used also Uptone ISO Regen, but removed it for now to see if it makes any difference with my issue, and it doesnt).

So, the quite strange behaviour I’m experiencing from yesterday is:

  • HQP plays / upsamples music, as standalone player
  • Roon plays music as standalone player
    When I try to play in Roon and send the signal to HQP (localhost), I can only see HQP as streaming, but not outputting to the DAC. Also, the volume in Roon (set to Device volume) does not appear to be the HQPplayers’ (which in HQP is set to -60db (min) to -2db (max)). There is a large negative number as the min (-2147483…) and 0 as the max volume in Roon and I cannot change this, even manually (picture attached).
    I don’t have any other output enabled in Roon, nor am I using any other sound app. I also disabled the Realtek sound card in Windows. In HQP I use WASAPI for my DAC.
    Many thanks in advance,

Hello @Zio_Pepe,

When you open your HQPlayer app, do you see the “Roon” playing information like shown here?


hi, John.
I appreciate very much your quick response. No, I didn’t see HQP playing and no playing info was displayed in HQP, after playback has being started in roon.
However just now I went into Roon, and for the n-th time today disabled direct DAC output in “Audio” settings, then added HQ Player localhost, without touching any further setting and voila!, the thing works again. Quite a mystery to me… I’ll report back in case the issue pops up again.
kind regards and thanks again, andy

1 Like