HQP works on its own but not through Roon with dietpi NAA. [SOLVED]

I knew my new found enthusiasm would lead me to trouble.

So I have diet Pi with NAA and no other software.
HQPlayer finds the NAA and play music form the RP1, optical out to my Chord Hugo Dac

I have set up HQP in Roon with the same IP address

However I get the following error.

when I click HQPlayer settings, I get a rather ominously minimal (non existent) set of settings.

Yet HQplayer plays away and I have the allow control from network selected.

I think I must be missing something fairly simple, but what is it?


The ip address you put into Roon should be of the PC running HQP not the pi running NAA.

1 Like

Thank you very much, very much case of RTFM, which I did, but obviously my preconceived idea of how it would work read what I wanted to read.


Ha ha. You are very welcome. As men we are all genetically programmed to not RTFM which is precisely why forums were invented!!! Hope you love the sound. As a total aside I went from a pi3 NAA, to fully optimized PC, and now I am borrowing a microrendu. All I can say is the the hype surrounding the microrendu is true! Now I just need to find some extra money to buy it!

Hi @Sloop_John_B,

Are you using the same computer for HQP and Roon Core ? If so, then type “localhost” in the IP address field of the HQP Network Zone. This will establish an internal connection from Roon to HQP rather than a connection through your router.

Some guidance on this KB page..

If it is a different computer then be sure to enable network control in HQP as per the link.

Thanks Andy, I’ve re read the KB and realised I had toally misread it.

They are indeed on the same machine, I had taken this to mean if I wanted HQP to play from this machine directly.

…I’ll get there!


1 Like