HQPlayer 4170 refusing to launch in windows 10 pro

Hi Jussi,
just updated HQ player to version 4.17.0 from 4.12.2 but it now refuses to launch the program in windows 10.
I’ve tried enabling AVX2 in powershell but still no luck.

going back to 4.12.2 & the program launches succesfully soi I’m assuming its not a problem with my machine.

I’m still running the evaluation version.

Admittedly My Desktop is fairly old is this the reason? :
|Processor|Intel(R) Core™ i7 CPU 980 @ 3.33GHz 3.33 GHz|
|Installed RAM|24.0 GB|
|Device ID|347BB1F7-3BDE-491C-8756-2F7741BEBF38|
|Product ID|00330-80000-00000-AA536|
|System type|64-bit operating system, x64-based processor|


Moved to hqplayer area.

Yes, this is the reason. AVX2 instruction set is current minimum requirement on Windows. AVX2 was introduced on 4th Gen Core CPUs. It is also supported by all AMD Ryzen CPUs.

On Ubuntu Desktop 20.04 LTS this CPU is still supported. And also on HQPlayer Embedded on Ubuntu Server 20.04 LTS and Debian 11. In addition there’s a special build of HQPlayer Embedded for Fedora 34 that works on this CPU.