HQPlayer Desktop thread


  1. Remove HQplayer zone
  2. Add zone again
  3. Reboot NAA
    (What happened is after relocation, a new IP was created after moving locations, updating everything fixed it)

Note: It seems some performance decrease from version hqplayer4desktop_4.20.0-98avx2_amd64.deb to hqplayer4desktop_4.20.2-98avx2_amd64.deb

Sinc-M with SEC7v showing dropping on Flac 192 Hz files.
After increasing buffering to 250 it was fixed.


About the Multicore setting. I have Core i5-11400T CPU on my server (6 cores). When I leave Multicore as grayed (auto) and play with DSD256/ASDM7ECv2/poly-sinc-gauss-long, I have around 15% of CPU usage, which is quite low. Music plays ok but when I play music and even slightly strain the server (like browse Roon albums or open the remote desktop connection) I get stutters.

Now when I select the Multicore with checkmark (forced on), there’s no problems with stuttering but the CPU load rises to around 30%. Obviously it’d be nice to use the auto setting with lower CPU and power usage but it gives stutter, especially with DSD256/48 upsampling.

Also is it better to configure Windows 11 to optimise processor scheduling for background services or applications when using HQP? Usually all the tutorials recommend using the background services option for audio PC. I also run Roon server on the same machine.

To my understanding of the muticore checkbox… the increased cpu usage is overhead required to make the multicore processing work.

It is more efficient without multicore but you need more processing power. You may only be at 15% usage but that is overall, what are the usages per core? If one core hits 100% you’ll get dropouts. You may not be able to see the core hitting 100% with a monitor as the refresh rate might be too slow and it may not visually show up.

On the i9 9900k that I use with Ubuntu (8 core, 16 thread), with most filters 2 cores do a majority of the work, the rest have low usage… by majority I mean between 50 and 85% usage on those 2 cores.


Thanks for the reply, very good points there. We went this through with Jussi and I think I’ll just keep the multicore checked as things work very well that way.

1 Like

my HQPlayer Desktop on my MacMini is constantly crashing.
I cannot listen for longer than a couple of songs then HQP CPU goes to 740% and I have to restart the Mac Mini.
Any hints how to narrow causes down and fix this?

Mac Mini … some more details about its hw configuration would be useful

… and your HQPlayer Desktop configuration/settings can help to understand

Ok, Thx, just a second, need to restart again, now HQP is crashing with the first song. :wink:

Mac Mini M1 8GB, Mac OS is still Monterey latest version.
HQP Version is 4.20.0.

I was playing DSD256, with poly-sinc-long-lp-2s, poly-sinc-short-lp-2s, ASDM7ECv2 to a Topping D70 via RPi4 with RoopiXL (which is probably not on latest version).

In the beginning all this worked well but now constant crashing.

Edit: Now its palying, CPU usage of HQP is 200% but also stuttering.
Strange I am pretty sure these settings worked fine in the past.

Edit: Switched to ASDM7, now CPU usage of HQP is 100%, no stuttering. Let’s see how long this lasts.

Edit: Not long, two crashes in a row. Does ist matter if these are streamed files or local files?

What if you use ASDM7?
Last RoPieee XL version is 2022.11.2 but shouldn’t be the issue

It looks like I could verify the issue.
I played all kind of tracks in different formats 16/44, 24/44, 24/96 and 24/192 local and from Qobuz and HQP never crashed (CPU usage always 100% with ASDM7), only with tracks in 24/48 from Qobuz (I do not have local files in this format), HQP always crashed!

Maybe your filter choice requires a lot of computing
You could try with these one

1 Like

Strange, poly-sinc-short-lp-2s, ASDM7ECv2 and DSD256 was working fliudly in the past, now it is stuttering. What could have changed?

Note that initializing poly-sinc-long to a rate not within the same family can potentially take a long time. When initialized once for a certain rate combination it is cached until HQPlayer is restarted.

But couple of minutes wait would be still normal with -2s. With non-2s it could day hours or days depending on computer and ratio.

1 Like

Perhaps anything to do with source rate family 44.1k vs 48k compared to output rate (44.1k base)?

Argh, what have changed?
I deactivated Multicore DSP! :flushed:

Now all back to normal. ECv2 works and 24/48 tracks also.

Sorry for all the fuss, as usual problem not in computer but in front. :see_no_evil:


Yeah! I was going to mention I have same settings with Mac Mini M1 8GB and works great! Good it’s fixed

1 Like

Version 4.21.0 on MacOs 12.6 Apple M1/8GB - NAA ver 4.30. Playing PCM sound is very very low. On SDM is normal. Any suggestions? Many thanks
NAA>Intona>DAC Accuphase DAC-60

You need to adjust the DAC-60 digital volume control on NAA to 0 dBFS and store the settings. I think I posted the instructions already earlier?

Note that in order to store the settings, if you are using the x64 image, you need to use the ordinary one instead of the ramfs one.

1 Like

Forgot about this part, haven’t listen to PCM on DAC-60 for a while. Will check on previous posts.

Is this right:

think I’ve gone through the steps couple of times, but one more time:

  1. Run “aplay -l” to list devices
  2. Take note of card number for your desired output
  3. Run “alsamixer -c cardno
  4. Adjust output volume to 100% (use arrow keys etc)
  5. Exit by pressing “Esc”
  6. Run “alsactl store” to store the settings for future restarts
1 Like

Yes, that’s the correct procedure. And it stays in the NAA if you use regular (non-ramfs) image.

On ramfs image you would have to redo it on every NAA restart, so not very convenient.

1 Like