HQPlayer Desktop thread

Sure! I don’t announce updates that have nothing worth announcing. There have not been any notable changes since initial 4.1.

1 Like

Yes I know but like today if you don’t ask me to test, I won’t know and I can’t test for you :grinning:

All with the aim of helping with continuous improvement !

I created a new build just for you to try… :wink:

But seems like best bet is to find hardware that uses DWC3 IP-block instead.


Works now, testing v2 modulators!

1 Like

Nov 4 2021 HQPlayer 4 Desktop 4.14.0 released!
Support for MP3 format, including ICEcast streaming. Support for PCM gain compensation. New ASDM5ECv2 and ASDM7ECv2 modulator variants. Support for RIAA EQ plugin. Support for TYER/TORY ID3v2.3 tags. Control API improvements. Streaming improvements. Sound quality improvements. Bug fixes and major component updates. CUDA support also on Fedora.

That’s a big release ! Will be interested in the streaming and SQ improvements as well as v2 EC modulators.


I have been having a play with the new ASDM7ECv2 modulators. I usually run Ext2 on Nx stuff and Ext3 on 44/16. My PC running HQ Player desktop runs between 80-95% on two cores at around 50c. Its a i7 9700 with no GPU installed. I am now having a go with poly-sinc-gauss-long for Nx and poly-sinc-gauss-xla for 44/16 still with the new modulators. Again around the same performance. Sounds great!


Seems like this guy had more luck with Rock960 board than Up Squared, regarding dwc3 (not that I have any issue with my UpBoard Gateway - only issue with RPi4 UAC2 input)


Wouldn’t be supported by HQPlayer though I assume?


I don’t have support for that Rockchip SoC. It is ARM-based hardware so it requires very specific support.

1 Like

Yeh that’s fair. Better stick to Intel based. Hard to find so far.

I’ve just made a beginner’s discovery: I’ve been using HQP and Roon without a preamp for a long time, managing the volume via HQP.
The evolution of my system has always been done with “fixed volume” on Roon.
By mistake, I changed this setting and I discover that Roon manages the volume of HQP.

For my information, this is identical to the volume button on the desktop version and the controls via the client or hqpdcontrol?
No degradation of sq even though volume is handled by roon as a remote?

Correct. You can verify by adjusting Roon volume and watching it also change in HQPlayer Desktop app.

The volume limits are also respected. So if you set -3dB max volume in HQPlayer, Roon will also max out at -3dB for your HQPlayer zone.


Yes, that’s the case.

@jussi_laako The latest version 4.15.1 is not working correctly for me. The PCM upscaling at 768K keeps interrupting. I had to roll back to the 4.15.0, which works perfectly.
My setup is M1 iMac => Ultrarendu => Holo May.

What kind of computer is this? Did you try with Multicore DSP checked vs grayed?

It is an iMac with the M1 chip. But I reinstalled the 4.15.1 version and now it works as it should. Thank you!

Hey guys, my apologies if this has been answered, but I’ve been racking my brain to try and figure it out for numerous nights without any luck.

I’m running a new MBP M1 Max. I can connect Roon → HQPlayer → DAC just fine. But, I wanted to test Apple Music, so I installed BlackHole 2ch.

In HQP, I’ve set the input device for BlackHole, and the output device to the DAC.

On the MBP, I’ve set the output device for BlackHole.

I’ve tried adjusting about every setting I can think of, given HQP mic permission in security settings, and so on.

Nothing I can do will get any sort of audio to appear in HQP (like it will when Roon is playing something through it). If it’d play something, I could at least troubleshoot bitrate issues (assuming there were any). But no matter what, I hit play in Apple Music, and nothing plays in HQP. Roon is also not running, and I’ve tried restarting all apps and the MBP.

I attempted to create a Multi-Output Device within MIDI Setup, but that didn’t seem to do much either (nor would it make sense to as I’d want HQP to determine the final output device).

Here are the current settings in HQP.

Any suggestions would be greatly appreciated.

Two CoreAudio cannot exist at the same time. One must be NAA.

After done the HQPD preference, go main UI and select the input, then hit play button on the top row. Then you can play Apple Music.

Thanks for this info. Would this mean that I’d need to set up a separate HQP client for NAA?

When I select either NAA option (IPv6 and standard), I get no choices/options under Device (the dropdown is just blank).

You can run NAA daemon on your Mac via Terminal.app. Please download it from:
Depends on you CPU please choose the file carefully.

Most likely you’ll see auto decompressed folder in your ‘Downloads’ directory. Open the Terminal.app then use this command:
Apple Silicon M1:
sudo ./Downloads/networkaudiod-arm64-412/networkaudiod start

Intel Mac:
sudo ./Downloads/networkaudiod-x64-412/networkaudiod start

Then try to select the input or output again.

1 Like

Thanks for this! I feel like I’m close now.

I have NAA up and running. The issue I’m seeing now is when I choose BlackHole as the input Device in HQP settings, it won’t save. It just reverts to Default after I hit okay.

Here’s the list of options for reference,