HQPlayer Desktop thread

It’s normal. Don’t worry about it, just play Apple Music. If you still feel strange, you can set NAA: BlackHole 2ch as Input and SMSL DAC as CoreAudio output.

Apologies, but I’m not sure that I follow.

When I play Apple Music w/ the above settings (as in my prior screenshot: HQP input as Blackhole via NAA, and output as DAC via CoreAudio), and the MBP system output as BlackHole, nothing plays through HQP.

If another change should be made somewhere, I’m somewhat at a loss as to where/what that’d be. I do appreciate your help on this BTW.

Did you select the input sample rate / channel in the main UI?


If you successfully start the input source (hit play button on the top row), you’ll see this:

Then you can play Apple Music.

The issue I’m having, is that nothing is popping up in that area. So, right now, I have Apple Music playing. The MBP system sound out is set to Black Hole. The HQP input is NAA / Blackhole, and out is CoreAudio / DAC.

I have never seen anything pop up in the tract section unless I’m using Roon or manually playing a file. With Black Hole and NAA, I can’t get anything to work.

Here’s what the terminal window says (if this helps anything),

Here’s the Midi settings,

Thanks for pointing that out. For whatever reason, I’d have never seen it.

That said, when I click the dropdown, and choose the correct sample rate, it just doesn’t do anything. It’s like it tries then fails. I have Apple Music playing, system out to Black Hole, etc. I’ve tried 48khz, 192, etc.

I see it say Start Core Audio Engine (or something like that) and that the Virtual Format Not Available in the bottom for a split second. If I choose the wrong sample rate, it throws another error, so I think that part is being read okay.

Here’s what the terminal says,

After restarting the app(s), I’m now getting this,



Thanks for this! So, I wasn’t clicking into the bottom area after choosing the source (another thing I simply wasn’t aware was needed by looking at this app). And, terminal didn’t have access to the mic, but that was an easy fix once I selected everything in HQP properly.

Now, I’ve got Apple Music playing through HQP. However, no matter the settings, I’m only able to get PCM. Does HQP have the option to convert to DSD like with Roon? I have the settings set to use DSD in Default Output Mode.

EDIT: I think I solved the DSD playback issue. Some setting needed to be retoggled on / off for whatever reason.

2 Likes

Congratulations!
Apple Music is just a beginning. HQP is an ultimate DSP can let you do advanced application. If you have a computer powerful enough to do multichannel DSD upsampling, you can use BlackHole ‘16ch’ to extract ATMOS or Dolby Digital audio track and do full ATMOS 7.1.4 multichannel room correction, multichannel DSD256 upsampling, or 7.1.4 to 2.0 HRTF mix down.

Here’s the example using BlackHole 16ch playing Apple Music ATMOS contents. Using Mac’s NAA to send ATMOS 8ch to Embedded server, ATMOS 5.1.2 to 2.0 HRTF mix down (for headphone), upsampling to DSD512x48, then NAA (yes, NAA again) to the endpoint. The SQ is waaaay better than AirPods Max.

3 Likes

Is Apple Music a true lossless streaming service on a MacBook (or MacMini) or you will need to upsample to a fixed rate via the Audio Midi if you want to output the audio to a USB or the Black Hole app?

Sampling rate auto switching only in iOS…

So I think it is of little benefit of running Apple Music on MacOS? Or am I missing something?

For me I only play ATMOS contents of Apple Music. And luckily most of the ATMOS contents are 48KHz so I just fixed at that rate for BlackHole.

2 Likes

I really appreciate the help!

At some point, I might look at integrating HQP into my theater. I have a 9.5.8 system with a Trinnov processor, (and lots of other fun gear) that I could try this all with. I also have a dedicated pc hooked into it with a 2080ti I had laying around, so it might be worth playing with.

However, my MBP M1 Max has been a beast when it comes to HQP.

I’ve been using HQP to convert DSD265 for my headphone setup (LCD-5s + HSA-1b & CRBNs + Carbon CC). I have a Holo May KTE that should be shipping any day now, so hopefully I’ll get to take things a bit further if the computer can keep up.

Been a big fan of HQP, but couldn’t figure the Black Hole part out. Never would have sorted it on my own.

1 Like

No, only ASIO has that limitation. You can use two CoreAudio devices, they just must be a different device. So you cannot use same device for both input and output.

For example I have RME ADI-2 Pro as input, and iFi iDAC2 as output on my iMac.

1 Like

Thanks for clarification. Sorry I misunderstood it. :sweat_smile:

It seems that the NAA/HQPlayer does not seem to send audio to the optical toslink on my MM 2012?

When I set output device to be the Core Audio / built-in output, oddly the audio is sent to the MM native speakers.

PS: I think probably BlackHole messes things up with the built-in audio output?

Ok let’s move back to Desktop thread. @jussi_laako @dabassgoesboomboom

Could you share your configurations (including Mac model, macOS version / VAD version / ANEMAN setup and network hardware / software configurations)?

If set DSD rate to 128 or 64 in my configurations, HQPlayer Desktop works well as expected. If set to DSD256 the SQ goes bad.

@jussi_laako just an update about my current situation.
After updated to v4.16.1 (x64), in HQPD standalone mode (no other remote controller), upsampling local files to DSD256 has no audible pops.
But if using remote controller such as HQPlayer4Client or Roon, the SQ goes bad. Audible pops sound appeared. It can be heard as soon as the HQPlayer4Client start running. Such pop sound even follows the mouse moving. :rofl: If set the rate to DSD128 or below the issue would be gone.
Based on my observation it probably related to the remote control implementation on HQPD for Mac.