HQPlayer Device Volume Not Working

Roon Core Machine

i7, 16GB

Networking Gear & Setup Details

Cat 6, Netgear GS108

Connected Audio Devices

HQPlayer β†’ NAA/SOtM SMS 200 Neo

Number of Tracks in Library

250k

Description of Issue

In device setup I get the option for both fixed and device volume. If I choose device volume the parameters match how volume is set in HQPlayer.

But I cannot control the HQPlayer volume from roon. Only fixed volume is enabled.

There have been quite a few posts on problems with build 831 iPad volume integration. I don’t know if something related is affecting other devices like HQPlayer?

Hi @tripleCrotchet, just to confirm, before Build 831 you were able to use Device Volume with HQPlayer?

If you switch to Fixed and switch back is there any change?

1 Like

TBH I actually cannot remember for sure now. I have had to send an old and difficult to source remote (with volume control) to Krell for repair. This has all coincided with the new build and was the reason I noticed the issue with device volume in the first place. Because I had no remote I was trying to control the HQPlayer volume from roon.

The functionality in Fixed or Device mode is identical in the sense that there is no roon control over the device volume. All that is different in each mode is that in Fixed mode I do not see the volume settings in roon (as set in HQPlayer) but in Device mode I do see these HQPlayer volume settings in roon, it is just they are inoperable, i.e. I cannot adjust the device volume from roon.

Hey @tripleCrotchet,

Thanks for the extensive description and incredible patience. We’re extremely sorry for only getting a chance to reply today.

Our team was wondering, can you control the device volume from HQ Player?