HQPlayer Embedded thread

for next release, please don’t forget to update /lib/modules/$(uname -r)/depmod* files too; a “depmod -a” and a reboot later everything is working fine for me; back to evaluating the software

obs: not sure if you want to have different configs between supported platforms, but i have 1-2 sec gaps while playing 44.1/48k from Roon to HQP running on rPi4 8GB upsampled to 768k PCM with default 1x filter (poly-sinc-ext2); i assume that the CPU in the Pi is not powerfull enough, because switching to poly-sinc-ext or lowering rate-limit eliminates this issue for me

Build tooling should be taking care of this, but seems like the BSP has some bugs after the updates.

I think I tested ext2 to work with auto rate family to 705.6k/768k when I was making the config file, but I could be wrong. But at least up to 352.8/384k should work. I assume you have cooling for the Pi?

It is fairly easy to have different config for RPi4 vs x64, so that’s not an issue.

passive cooling - a “full” aluminium case from CoolerMaster that came with my rPI4 kit, so CPU might be actually throttled; who knows - i should run a few more tests, when i take a brake from work and listening to music :slight_smile:
briefly tried to overclock the CPU, but that didn’t seem to work and i temporarily abandoned the idea

@jussi_laako, what’s the difference between 4.32.0 and

Just some minor build fixes, mostly related to above mistake that modprobe wasn’t configured for all the supported module compression methods.

If you are not experiencing problems, no need to update.

Does this still work? Just tried but I receive this error
Failed to stop hqpwv.service: Unit hqpwv.service not loaded.
Failed to disable unit: Unit file hqpwv.service does not exist.

Try systemctl status hqpwv ?

If it isn’t running, nothing to disable :slight_smile:

You’re right … but I tried HQPWV few days ago and it worked … now it doesn’t work anymore …

… now I remember … I tried on 4.31 then installed 4.32 and maybe the service is disabled by default ….

1 Like

Tried to enable it but it doesn’t exist anymore …

1 Like

Tried to mail you a log file from my shaky HQPe, but you are still checking, I assume?

Here’s two screen shoot of the HQPe while going, the first one does not stop any playback, the second however, does.

Pls let me know what you think of these additional informations, if the clarify anything? Only thing here is to restart HQPe. Often it will operate flawlessly after restart, but it may well be other restarts following later.

I responded over email.

I would also recommend letting memtest86 run overnight.

Because I was chasing such problem on one of my servers for several days, just to find out that the RAM needed to be replaced…

Yes, HQPWV was removed on 4.32 release. Dealing with all the node.js stuff became too much of a problem on recent OS upgrade and HQPWV seems to have become unmaintained.



Ahhh, off course. So many years ago, but at the time of building pc’s on window 98, XP and Vista, I encountered a faulty mem stick causing very erratic behaviour.

Thanks for the reminder! Will check this asap. Will send a small note via mail, if it was successful.


Interesting, with ALSA vs NAA with my 11900K (and 9900K), NAA results in slightly higher CPU loading than ALSA.

Maybe HQP Embedded is optimised different for 12900K and 11900K

I observed CPU utilization rate when using NAA in EC → 1024 scenario was roughly 3% less than USB thru ALSA for the two main P-cores. Sometimes this 3% would make 192->EC->1024x48 success.


Ah k. Maybe I wasn’t looking at the 2 highest loaded cores with my 11900K.

I think I was looking at overall CPU loading being a little lower with ALSA, but maybe 2 cores were higher.

Interesting observation though.

1 Like

Yes, it’s an amazing observation knowing that 3% or even less may have a huge difference for HQP when we squeeze every single last drop from CPU, not necesseraly in for 12k…

1 Like

Not only NAA would help but also L2 / L3 cache speed matters. I tried parameters for ring from 29x (auto) to 45x (capped, unstable), I found 42x was min requirement for 44.1 / 48 family → AMSDM7EC → 45 / 49MHz. Ring 44x sounds best but only suitable for 44.1 / 48 family → ASDM7ECv2 → 45MHz on my i9 server.

So I loaded up HQP OS Embedded on a USB drive and tried to give it a whirl (version 4.32.1) and there was nothing I could do to web login. I had the right IP and just nothing. I could ping the computer everything just no response in web browser Chrome or Edge all firewalls and everything off.
So I thought I would give an earlier version a go just in case and (4.31.0) worked first try boom. Is there something that I am missing with the latest version that isn’t documented?

I wasted a bunch of time re flashing and trying on 3 different computers cables etc,

What am I missing?