HQPlayer Embedded thread

HQP Embedded hqplayerd xml
set multicore=“1”

Fans aren’t breaking a sweat which leads me to believe there’s untouched potential with the cpu. Need to find a drive to make a new ubuntu install on. I’m running low on drives it seems. How in the world has this happened! I’m slipping! :scream:


HQP Desktop runs fine on the machine?

Just EMbedded has issues?

well I just built it, only have macOS 12 and windows 10 drives now. I had a spare drive with ubuntu working on the machine but I pulled it to use as a working spare for opencore setup. :face_with_diagonal_mouth: maybe I’ll try it in windows. That’ll be easiest right now. I’ll work on Ubuntu tommorow.

Lemme go over to windows and futz… to the dark side! :scream:

1 Like

Once everything is sorted, no more changes! :rofl:

Pipe Dreams… Well that didn’t work. The only thing windows is good for is games and emulators. Mac is only good at saving power. I used to like macOS but that is getting worse as the numbers climb. oh well… I was hoping hqplayer os would just shine with flying colors. Bios are pretty much stock settings aside from XMP profile and fan curves.

I’ll mess with ubuntu tomorrow. Once i sort that, then all futz with hqplayer OS. Though there’s really nothing to futz with… :thinking:

1 Like

I couldn’t leave it alone. I pulled the Ubuntu drive from the 9900k. Threw it in the new machine. Updated Ubuntu. There’s definitely a power management issue as it even gets dropouts with sinc Lm ASDM5 @ 512 48k.

Definitely won’t be bored this week. Lol.


Check Turbo Boost is on

That’s all I can think of lol

It boosts quite high. Hits 5.8ghz. Only seeing 5.5 in Ubuntu but I believe that is from avx usage. The bios in asus is a bit different than what I’m used to in gigabyte boards so I need to poke around a bit.

It’s not as exciting as the 9900k. Too many cores now I think. :wink:

1 Like

On my ASUS board, PRIME Z590M-PLUS with i9-11900 cooled by Noctua NH-L9x65, I needed to set a non-standard cooling profile to avoid thermal throttling and hiccups with ASDM7ECv2 @ DSD256 when it gets warmer here (we have no AC as Northern California was once believed to be temperate year-round). You may be able to play with that BIOS interface, it’s actually quite nice as it allows you to set up performance and cooling parameters easily.

1 Like

It actually is running quite cool considering the clock speeds. Oddly enough things are working better in windows10 :astonished: than in unbuntu with a fresh install. Ubuntu still gets dropouts so something is clearly sill not setup correctly in ubuntu. :thinking:

I have not been able to get more complex and longer filters to work with 7ECv2 DSD512 without enabling cuda. With cuda all combinations seem to be attainable and the machine is quiet and tame currently running at under 50C while playing 192k/24 → DSD512 48k with sinc-L ASDM7ECv2. :face_with_raised_eyebrow: I can’t try DSD1024 as I have nothing that will accept it. Time to get a Spring or a May. :star_struck:

I gave up on embedded until I get desktop to work.

gauss xla with 7ECv2 seems to be a hungry combo, I’m getting 22% usage and ~28% out of the GPU. but temps are running about the same around 50C. So usage is a bit more than sinc-L.


Maybe Ubuntu can’t control P core and E core. I have E core disabled. I think that it will be solved if the ubuntu kernel is upgraded.

You can see this from HQPlayer log file, it reports number of P and E cores.

12th Gen CPU shouldn’t be a problem. 13th Gen requires relatively recent kernel version.

I’m using 13900k with ubuntu kernel 5.15.
Closed-form 16M, DSD512 makes the sound skip.
However, when I disable all E cores, the sound does not skip.

If you do “sudo apt install linux-lowlatency-hwe-22.04” it should pull in 5.19 now and solve your E core problem.


thank you. i will try.

I changed the kernel to 5.19.
Even if all E-cores are enabled, the sound will not skip.
thank you.


This afternoon I have gotten ubuntu 22.04 working and it is less exciting than windows which is more in line with how I expect hqp to run in ubuntu.

I am now using 5.19.0-1018-lowlatency with newest nvdia 5.25 (proprietary-NOT opensource kernel) drivers. (which I believe I was using before but idk… it now works)

Checked the log as suggested by @jussi_laako, all P and E cores are recognized.

I have all P and E cores enabled but still require cudu offload for Mx L and LI @512 DSD.

But compared to my previous post with sinc-L in windows, ubuntu cpu usage is much more relaxed.

This, as easy as it sounds, will be a more/most difficult to achieve. :smile:


hello. Where did you write these commands?

I am in the blessed situation to have HQPlayerd runnig beautifully on my pc;
Ubuntu 22.04.2, HQPlayerd, HQPlayer Client and now finally all files from Qubuz resamples to DSD256, DoP, ASDM7ECv2, poly-sinc-gauss-xla. I cannot say I have ever heard the x-ray vision of music irrespective of price tag and brand. It just sounds music and at no point, I halt and start listening to the sound. Now, is it possible to route Spotify playback to HQPlayerd? Got the Spotify app in the Ubuntu OS. It plays well as is to the RME DAC, but I know what HQP can do also with information not so good. Is it anyway I can simulate HQP to be the "sound output, seen from Spotify. Will not add more devices, I am currently fighting to reduce all the sh*t I have and the abundance of cables in between. It would be so nice to also invite my wife and here stubborn attitude against all other streaming services than Spotify. That way I can enjoy her playing as well, as here musical taste is impeccable.

So directly from the app Spotify to the app HQPlayerd, installed on the same computer and out via USB, clean and tidy to the RME DAC. Possible? :slight_smile:

1 Like

On a Mac i can, using BlackHole

I’m sure a similar method exists for Ubuntu. Someone else will have to help though because i don’t know

Alternative solution is to add two SMALL devices :grinning: small Toslink streamer that supporte Spotify Connect and miniDSP USBStreamer

1 Like