HQplayer fails to start on VM/Hyper-V and on host server

Hi, for some reason I’m unable to start HQplayer on my server, both the actual host and on the VM’s no matter the operating system.

Could this be because current versions have a different requirement?

I have tried reinstalling, uninstalling, cleaning, etc. but the same error always appears when starting HQplayer4Desktop.exe.

“HQPlayer4Desktop.exe has stopped working” - Close the program (See attached image for more info).

In the windows event log the same error also appears each time:

"Windows cannot access the file for one of the following reasons: there is a problem with the network connection, the disk that the file is stored on, or the storage drivers installed on this computer; or the disk is missing. Windows closed the program HQPlayer4Desktop.exe because of this error.

Program: HQPlayer4Desktop.exe
File:

The error value is listed in the Additional Data section.
User Action

  1. Open the file again. This situation might be a temporary problem that corrects itself when the program runs again.
  2. If the file still cannot be accessed and
    • It is on the network, your network administrator should verify that there is not a problem with the network and that the server can be contacted.
    • It is on a removable disk, for example, a floppy disk or CD-ROM, verify that the disk is fully inserted into the computer.
  3. Check and repair the file system by running CHKDSK. To run CHKDSK, click Start, click Run, type CMD, and then click OK. At the command prompt, type CHKDSK /F, and then press ENTER.
  4. If the problem persists, restore the file from a backup copy.
  5. Determine whether other files on the same disk can be opened. If not, the disk might be damaged. If it is a hard disk, contact your administrator or computer hardware vendor for further assistance.

Additional Data
Error value: 00000000
Disk type: 0"

There is no issue with the disk, as I have tried several, neither is the application not installed correctly or missing in any of the paths used.

Reason is that the E3-1240 v2 CPU doesn’t have support for the AVX2 instruction set needed by Windows version of HQPlayer.

If you want to use HQPlayer on that hardware, you can get around the AVX2 requirement by using Ubuntu Linux (currently still 20.04) and generic build of HQPlayer there.

Thanks Jussi, I suspected this… to bad though I’m happy with my Win server installtion and previous version was working fine but Roon suddenly required update and well here I am unable to use it now :smiley: