Huawei P30 can not access roon app

Core Machine (Operating system/System info/Roon build number)

Innous Zenith

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

D-link router and network switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

I’m using Huawei P30 mobile phone and installed roon app but it can not access the roon app, keep searching the roon core. Please refer to the attached photo.

However, my iPhone, iPhone pad and LG V10 mobile can access to the roon app. They are all using same wifi network.
Please advise how to fix it.

Hi @Young_Danny,

Thanks for reaching out, I have a few questions to begin troubleshooting:

  • Is there any change if you reinstall the Roon app on your P30?

  • Are you on the same subnet as your Core (same IP except for the last 3 digits)? You can use an app such as FING to check.

  • Are you using any VPN(s) on the P30?

  • What kind of switch are you using - what is it’s model/manufacturer? Is the Core connected the the switch or to the router?

Hi Noris,

  1. NO. I tried to delete and reinstall the Roon app on my P30, still can not access to Roon app.
  2. Yes
  3. No
  4. D-link switch TGS-108L, the core is connected to Fiber Transceiver, then connect to switch.



Hi @Young_Danny,

Thanks for confirming the above.

Does your router by any chance have IGMP Proxying or IGMP Snooping as a setting? Is there any change in behavior if you try to temporarily enable these features (one at a time and then both)?

IGMP has helped uses with similar issues in the past, so it is worth a try.

2 posts were split to a new topic: Roon Remotes not working when connected to access point

I have the exact same problem with my Huawei Mate 20 Pro and in the same time Roon app run flawlessly on my old LG V10 and Sony XA. So may be this is some problem with Huawei devices if you can investigate it.

Hi @Alexander_Gospodinov,

What model/manufacturer is your router? Have you tried enabling IGMP Snooping/Proxying and there was no change in behavior?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.