I am so tired of losing my connection to Roon

This is the 4th time I have asked the community for help. 3Times ago, I sent my Roon Nucleus to be services - 8 weeks later I got it back. This is terrible.

Once again, my power went out, the generator kicked in…and I can no longer find my Nucleus. I plug in a monitor and there is nothing from the ROON. Nothing. The monitor will not pick up a signal. If I wait 2-3 weeks, it will probably solve itself. In the meantime, I hook up an old laptop to the same configuration and it works fine.

Roon, your hardware is terrible. And your support is worse. You should be happy to send me a replacement while you fix the shoddy product you sold me.

Please make a suggestion to help. I am wore out of poor hardward and worse service.

I get it that you’re frustrated, but there is nothing fundamentally wrong with Roon or the Nucleus. It’s more likely the environment in which it operates, i.e., network.

If you’d like assistance, please provide complete details on your setup as described below plus the errors and messages you are seeing. It would be great if you could share screenshots and describe the steps you have taken to resolve the matter.

I hate to say it but power spikes are killers. In South Africa we get what are called “load shedding” ie planned power outages sometimes twice a day :sob: I must be the Roon expert on startup :smiling_imp:

I have a UPS not specifically to run things during outages but to protect my kit on shutdown and startup. The UPS allows me to shutdown “gracefully”.

After a power outage , how do you restart?

My technique is tried and tested sadly far too often …

Unplug everything, start at the modem and work forward allowing each component to fully start before moving on. You get to drink lots of tea/coffee

Starting the Core before your internet connection is up and running will often prevent Roon from connecting.

There is always the possibility that your generator start up may have surged and fried something.

Try an absolute cold start and see what happens

1 Like

Hi @Brian_Helgoe,

I’m very sorry to hear about your Nucleus, and I empathize with your frustration. It’s disheartening to experience recurring hardware issues - it’s maddening when your requests for help go unanswered. My team is eager to make things right and restore your system’s functionality as soon as possible.

We can troubleshoot most efficiently if we have full details of your network system and setup. When you have a moment, would you please provide some brief answers to to the questions below?

Just to confirm, the Nucleus’ HDMI outputs fail to display any boot or diagnostic information when connected to an external display? If you can get any information to display, please include a photo.

I assume you aren’t experiencing any general issues with your network connectivity outside of Roon on any of your endpoints?

If you access the Nucleus web admin page from a browser, can you please share a screenshot of the page? In particular, the RoonServer and Networking sections will provide clues as to the status of the device.

Frequent power outages (and any resulting voltage spikes or static blasts) could have damaged the unit’s power supply. The Nucleus PSU is 19V, center-positive (specs here). If you happen to have a separate power supply matching those specifications, it’s worth testing it to rule out a PSU failure.

We’ll be standing by for your response when you have a chance to share the screenshot. Thank you again for your continued patience - we’ll sort this out as quickly as possible.

Hi Conner, thank you for the quick reply. I was frustrated last night. I hope to get this fixed.

Roon Core Machine

Sn 54B2039C539A

Networking Gear & Setup Details

Directly plugged into Frontier router

Connected Audio Devices

McIntosh MA12000
Connected via USB

Number of Tracks in Library

Maybe 1000

Description Of Issue

Regarding surges: my whole house is on a very good surge protector, essentially there are no surges or delays in any part of my house. If the power goes out, everything shuts down like getting unplugged. The power restores in about 10 seconds only after the generator is running and the surge protector conditions the energy coming into the house

I think the problem is with the Nucleus not getting found after the WiFi comes back on. When I plug in a monitor via the HDMI cable, there is no signal. (If you search a previous post in my name, you will see the photos). After 2-3 weeks, the nucleus gets found by the WiFi, the HDMI reads the IP address and all works fine.

The photo above is from the last time this happened after being unresponsive for a couple of weeks.

For clarity, the photo of the monitor last night would say it is not receiving a signal from the connected device (the nucleus plus)

Hi @Brian_Helgoe,

I appreciate the level of detail provided. Thank you!

Do you know the model number of the Frontier-supplied router you’re using? The more details you can provide us with about your network hardware, the more light it will shed on the issue.

Your previous post suggests that there may have been an IP address assignment issue to blame the last time this problem appeared.

Do you know if you had assigned the Nucleus+ a fixed IP address the last time it was connected? You could try re-booting your router and any network hardware in the meantime.

Brian, when the generator starts, how long does it take for your Frontier router and internet connection to become active and pass traffic to/from the internet? Also, are you on Frontier DSL or fiber?

1 Like

Hi Connor,

I will send you the frontier modem model number tonight when I get back home. I never assigned the nucleus a fixed IP address - I don’t know how to do that. Happy to try it. Thanks again for the quick response.

1 Like

Hi Connor, the frontier router serial number is
It connects via fiber

The Roon nucleus is directly wired into the router. Everything else in the network is working well.

Thanks Rugby….

The model number is NVG468MQ

Hoping someone from Roon Support can give some help today. Communication trail has gone quiet.

Still no signal from my Nucleus.

Hi @Brian_Helgoe,

Are you able to log into your Frontier router’s user interface to verify that the Ethernet port is functioning properly? You could also test the Ethernet port of the router on a computer with wifi disabled.

Using the IP address for your Nucleus (it will be listed in the HDMI output), you can access the Web Administration page for the device in a browser.

If you’re able to reach this page, please take a screenshot of the “Networking” section and post it to this thread. This will give necessary clues as to whether the issue is hardware- or network-related.

Please let me know if you can reach the Web Administration page and supply the screenshot. We’ll have additional troubleshooting steps from there.

I’ve set this thread to alert us on all channels soon as you respond, and I apologize for the delay. You can anticipate a faster response time from here. I appreciate you working with us to find a solution!

Hi Conner,

There is no signal coming from the HDMI. As such, I can’t get an IP address.

The Nucleus is hardwired via an Ethernet. If I go to the up address web site that lists everything on my WiFi, there is nothing for the Nucleus; moreover, when I use the Ethernet cable from the Nucleus to plug in my computer, the same website immediately sees my computer join via the Ethernet.

Hi @connor or anyone from @support

Sounds like my Nucleus is not going to work and the thread has gone cold. It’s less than a year old and this has been happening since the beginning.

What are my options for a replacement?

1 Like

Hi @Brian_Helgoe,

I know you’ve endured a frustrating lack of attention throughout this process as a result of some internal personnel changes on our end over the last few weeks. While I wanted to provide some context, it’s not an excuse, and we apologize this has been your experience.

Before we escalate to boxing up and shipping the hardware, if you have the patience for one last short test, please try the following:

  1. First, connect the Core to your router via Ethernet
  2. Connect the HDMI A output to an external monitor (no information displayed, I assume)
  3. Now, disconnect the Ethernet cable from the Nucleus. Does the monitor now display a “Searching for Network” screen?
  4. Reconnect the Ethernet cable.
  5. Diagnostic information (including IP address) might now be displayed on the monitor and Web admin.

If there’s an IP address listed at that point, please let me know, and we may be able to restore functionality quickly with limited back-and-forth. If this test doesn’t work, we’re standing by to start a private message feed to discuss options otherwise.

Hi Connor,

Apologize for my delay.

There is nothing. No signal. I tried 3 times. I even shut it all down again and restarted. Still nothing. See photo of the monitor.

Please let me know how to return.

This topic was automatically closed after 45 days. New replies are no longer allowed.

Hello @Brian_Helgoe ,

Sorry to hear that you’re having issues here, it’s certainly strange that this is the 2nd unit that you are getting no signal on.

As @connor mentioned earlier in the thread, power surges such as these can impact the Nucleus hard drive from operating properly. If the Nucleus was writing data to the drive at the time of the surge, you might even get the database into a corrupted state, which can cause other issues.

If power surges are a frequent issue in your area, please strongly consider adding a UPS Battery Backup, these are not too expensive and there are plenty in the under $100 price range. For an expensive unit such as a Nucleus, this kind of protection would be very worthwhile.

I’ve followed up via private message to get shipping detail, I’ll escalate your case over to our RMA team for further review after. Thanks!