I can no longer access any files that are on the two external drives connected to my Mac Mini

Roon Core Machine

I am using Mac mini 2016 model with M1 chip, and am running MacOS 12.3.1
Roon version is Roon 1.8 (build 923).

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Everything has worked fine previously. I have two external drives - Lacie which still connects and WD which is not connecting and on Roon the following appears

This directory appears to be empty.
Add some files or edit this folder if it’s been moved.

When I click on the folder tabs I see

Error loading folder Unauthorized.

I have the same problem with an attached Raid array. I used to have access just fine, but now get the message:
This directory appears to be empty.
Add some files or edit this folder if it’s been moved.

Hi Andrew. Have you been able to fix your issue?

Are these affected drives possibly NTFS formatted?


No, they are MacOS (extended). Not sure if Monterrey upgrade caused the problem or the last Roon upgrade.

No I have not.

I’m not sure either, I suspect the last Roon update because I think that was the most recent change. My Mac mini recognizes the WD external drive and all of its contents. It is the Roon core that cannot see the files and reads the drive as empty.

My symptoms are exactly the same. I am on an iMac (2020 with Intel i9). The external drive is a Promise Pegasus 2 R4 Raid array and it is mac formatted. I wonder if we un-install and re-install Roon if that might fix? Other ideas?

I need to be sure that nothing will happen to my files when I uninstall Roon. I have all of them backed up on a second external drive so I suppose it might be worth trying that. I have also thought about purchasing a new external drive and seeing if that might work with Roon. I am pretty sure this problem started with the last Roon update - and there was another one today - and not with Monterey which has not given me any problems so far.

Hopefully someone from Roon will have advice?


I discovered that in addition to authorizing file access to roon, you need to authorize “full disc access” in the privacy settings. Not sure if this is a new requirement or if one of the updates switched it off, but it is now working form me. LMK if you need more details.


Hi @Andrew_Verhalen & @Paul_Sayegh ,

Yes, this is correct and has always been the case. Paul, can you please try this setting and let us know if it helps in your case too?

Noris, My system used to work fine. Would a Roon upgrade or the upgrade to Monterrey have changed this setting? Seems curious that this would get changed without me doing it…

Hi @Andrew_Verhalen ,

Yes, it is very possible that an Operating System Upgrade reset the settings in this area. If you flip this setting again, does that restore functionality?

Yes, once I fixed that setting, it all worked fine again. I just was curious about how it got changed. Thanks, Andy

1 Like

Yes, after Andy and I discussed, I changed my settings and everything was back. Thanks Andy for the help and Noris for following up.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.