I can not add Synology DS412+ to my library

Core Machine (Operating system/System info/Roon build number)
Roon 1.7

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
DS412+, Roon non Rhein Z1V2, via ethernet cable

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Ethernet to Moon 390

Description Of Issue
I can not import (network share) music on NAS to Roon, folder is pubic, tried every suggestion on your site + dealer suggestions.

Can be more specific ?

What error message are you seeing? How are you trying to connect?
Screen shots ?

What exactly have you tried?

1 Like

tried ad networkshare, :\DISKSTATION\music
as well as some other like my dealer sugessted:


addden Netwerk before all above, no result, bu could not connect.
made suhre nas is SMB, folder is shared.

Error message: could not connect to share, Host not found.
Also tried in storage > ad folder. Also no succes.

Anyway My Moon 390 found all my music, I have besides the diskstation also 2 WD-Mycloud as well as my Naim music streamer.

Hello @Bing_Teng, and welcome to the community! My apologies for the issue here, could you please share a screenshot of what you’re seeing when you try to set up the share? Also, what are you using as the core? How is the Core and the NAS connected to the network?


It is Roon 1.7.
I use Rhein Z1 as core which is directly plugged into my Silent Angel N8 networkswitch, as is my Moon 390. The Nas is an Synology DS412+

Hello @Bing_Teng, any luck if you connect the NAS directly to the router and temporarily bypass the switch?

My Nas is directly connnected to the Router in my workroom, the switch is in my living room with my Hifi? Anyway my trial ends soon so I need an quick solution.

So I can not bypass, Because Roon server and Moon are in another room.

However, it should make no difference.

Hi @Bing_Teng,

Do you know the IP address of the NAS? Can you try using that like this:

smb://[IP ADDRESS]/music

Does that work for you? Make sure you are also entering the username and password for the NAS as well.


Off course I also tried that but it came with the message: Empty folder…

Anyway you can close the topic since I ended my trial since the support was too slow.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.