I can’t connect through Roon to Qobuz

I’m on Switzerland with a french account and since 2 days I can’t connect through Roon To qobuz.

Can You do anything???

I have changed to Audivarna yesterday and connection is perfect. Why not with Roon ?


The Roon @support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. hence I split out your topic.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Hello @Didier_Duvanel, just checking in, are you still experiencing issues with Qobuz? We’d be happy to help if you can provide some details about your setup!

My problems are coming from the processor in my imac where the core is currently located. When Qobuz freezes, I have to reboot the computer. That’s why I’m switching to a Nucleus as soon as it gets here.

iMac Retina 5k 27 inch 2019
Processor 3,6 GHz Intel core i9 8 cœurs
Mémorable 64 Go ddr4

macOS Catalina. 10.15.5

Roon 1.7 (build 571) stable


For more than 1 year all was good. But since about 1 week, very often i don’t have connection to qobuz. I shut Roon and re-open Roon without résultat. Same when i reboot my imac: no result.

I always have connection with qobuz through qobuz player or through Audirvana.

Do You have an idea? Thanx.

1 Like

Hello @Didier_Duvanel, do you see an error message when you notice Qobuz isn’t working? Does this happen on all endpoints?


No error message. All favorite qobuz albums suddenly disappear from my Roon bibliothèque. In settings, services, a wheel runs endless near by qobuz. After many hours the wheel disappears and al my favorite qobuz album can be seen and played again.

Sometimes an error message comes when music suddenly stops in thé middle of a piece: this album isn’t disponible on qobuz.

Just now I had this problem and after a few minutes, music go on again without I do anything.

Same problem here! I am located ib Germany, have Qobuz and 1.7 built 571 and run on OS Catilina.
Many problems with Qobuz, yesterday the “delete old files” deleted 20 albums I had downloaded from Qobuz because it coulnd´t (temporailiy" not located them anymore.
I am very disappointed…

Hello @Didier_Duvanel, could you please describe your network setup for me? What router you’re using, any switches, etc.? Thanks!


I have a Swisscom internetbox 3 with speed 10 Go Up/down and a direct lan ethernet to my imac. No switch.

Thank You.


Very often I receive an error message when I try to play a qobuz album "this album isn’t disponible on qobuz. "

I do nothing and after 5-10 minutes thé play begins itself.

Hello @Didier_Duvanel, have you tried Google or Cloudflare DNS to see if this helps? I’d recommend changing DNS servers and see if that helps.

Hi @nuwriy!

Yesterday I changed Swisscom DNS for Cloudflare DNS.

Today I had to close and run again Roon. Since I could play 3-4 Qobuz album. I’ll test still 1-2 days and I come back here.


Hello @nuwriy,

Sorry, it’s not ok.

When I have read an album on my hard disk, and if I change for qobuz album, I have to wait for many minutes before music plays.

Picture of the qobuz album immediately comes onto the screen of my Cambridge Audio 851 N , but Roon says: This piece of music is actually not disponible on qobuz.


Hey @Didier_Duvanel, the good news is we’re getting closer! Do you see this issue playing to system output of your iMac?


Some news: I have less problems; I can change playing many times between my own albums and qobuz albums without problems. But suddenly Roon can’t read a qobuz album and I can no longer do anything: not play qobuz album, not play one of my albums. I have to wait with the message “this album isn’t disponible actually on qobuz” till suddenly playing continues itself.

Or I often can play qobuz albums but suddenly in the middle of an album music stops with same message.

Problem is same on Cambridge Audio with lan and on Bose Home Speaker 500 with airplay.

I still have to test with built-in output on my iMac. I come back after one or two days.


Hello @Didier_Duvanel, thanks for the update! Yes, please try system out on the mac and let me know what happens.

Hi @nuwriy,

I think I have found the problem!!!

I tried with system out on the Mac. Everything went good… till Roon synchronize qobuz library. Immediately playing qobuz streaming stopped.

On my Cambridge audio it’s same. And once Roon stops I can’t do anything (not playing my own library) without closing and running Roon again.