I can’t get Roon to recognise my IPAD pro as a Roon Endpoint

Core Machine (Operating system/System info/Roon build number)

MacBook Pro 2014/MacOS 10.12.6/Roon Version 1.6

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ASUS RT-AC86U with latest firmware.
MacBook Pro on 5ghz band
IPad Pro on 5ghz band

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ipad audio output

Description Of Issue

Running Roon Remote on Ipad. Cannot see the Ipad as an Endpoint in Roon Settings/audio. Have done a complete reboot - no change. Please advise.

I have the same issue when I use my iPhone 8 Plus with Roon Remote. The Roon Core cannot see the iPhone or iPad as Endpoints

Did you go to Settings > Audio on the iPad and iPhone or did you just go to Audio Settings from the MacBook?

To see the iPad as a Zone from the MacBook, you need to Enable it from Settings > Audio on the iPad. Then in Device Setup for the iPad, click Private Zone to No.

If that doesn’t help, do you have the Firewall active on the Macbook?

Cheers, Greg

Hi Greg. Thanks. Firewall is off. Unfortunately, I cannot find the IPAD Endpoint both on the Ipad and the Macbook. I have attached screen dumps from both machine here.

Any Antivirus running on the MacBook?

Other than that, I’ll tag @support for help.

Cheers, Greg

Yes. Bitdefender. But just the antivirus function. To be safe, I turned off Bitdefender and it is still the same status. Roon can detect the Apple TV, Google Home and Chromecast endpoints. But not the Ipad and iphone.

It should work with Bitdefender disabled. If you’re going to use it, you need to allow Roon and RAATServer through.

Your issue appears to be that RAATServer is not being allowed through by Bitdefender.

Airplay and Chromcast don’t use RAAT.

Cheers, Greg

That’s the Mac screen shot I think, what does the iPad screen look like? “Connected to this tablet…”

The second image is the ipad screenshot. I do not have the “Connected to Tablet “ showing. Clarification - I am running Roon Remote on my Ipad. Is that 5e right way to do this?

Correction. The first image is from the Ipad pro

Have you re booted your iPad? Just a thought.

I just checked again. I have only the antivirus version of BitDefender, and the MacOS firewall is off. To be safe, I stopped Bitdefender and tried to connect again. The IPAD can connect to the Roon core (though after a bit of time waiting) but I still can’t see the Ipad as an Endpoint. I do not have the “Connected to this Tablet” section. Is there a setting that I need to turn on on the IPAD to allow the RAATServer to function? it looks like a ‘local’ issue at the device as the Roon Remote app on the Ipad can’t see the Ipad?

I have the tried the ‘reboot’ option at least 3 times now… A bit frustrating.

Could be an IOS issue. I just installed Roon Remote on an old android tablet. I can see the android Endpoint.

You could try deleting the iPad app and adding it again.

Thanks. A bit puzzled with what is going on. I reinstalled the app on the Ipad and here’s my experience on both the Ipad and Android tablets:

Android: Quick connection to the Roon Core (less than 15s) and I can see the Android Endpoint in Settings/Audio. Stable

Ipad: Connection to the core takes time. Not unusual for 5-10 minutes, with a couple of App restarts. After connecting to the core, I will need another 5-10 mins to see the Ipad as an Endpoint - sometimes I need to restart the App. Getting the “Connected to Device” function is not guaranteed. Intermittent.

Access is through the same wifi network.

What happens if you turn off AirParrot? Is that getting in the way of the Mac/iPad communication?

Airparrot is not running

I do think it is as it says to this Mac, it should say to this tablet.

To be on the safe side, I uninstalled airparrot and removed the audio Drivers. No change in status.