I Cannot connect to my core [Solved: Newer QPKG required]

I have Roon installed as a server on a qnap tvs471 using the instructions from your site. I havent been able to open a roon remote, or the roon app in from in the qnap for some time now. The screen askes my to choose a core but it cant find it.

Hi @Jake_Sager — Thank you for the PM, sorry to hear of the troubles. We typically handle any support questions in the “support” thread on the community site. This allows other users to have access to any advice or troubleshooting tips that are shared, should they find themselves in a similar situation. Would you mind if I made this PM a public support topic and we can continue troubleshooting fro m there? Let me know.

Furthermore, can you please expand on the details of your setup, using this link as guide. Additionally, may I very kindly ask you to please provide me with the following:

  1. During your troubleshooting of this behavior have you tried rebooting your QNAP, remote devices, and any pertinent networking hardware to determine if the remotes can find the core while everything is in a, “fresh state”?

  2. You mentioned the following in your PM:

    " I havent been able to open a roon remote…for some time now."

    • By the sound of it, your Roon remote functioned at one point, has there been any changes to your setup, since that time?

    “I havent been able to open…the roon app in from in the qnap for some time now.”

    • Can you pease clarify this statement for me?


That’s fine if you want to make it public. I wasn’t sure how to begin and didn’t realize i started in the wrong place.
I have rebooted, that hasn’t changed anything. The remote has worked in the past. I’m not aware of any changes.
I’m using 64 bit windows 7 on my computer which is set up as a remote. i also have an ipad with the remote app as well.
i don’t know which version of Roon i have. I cant get in. The only screen i get is one asking for me to choose a core. Ive tried to input the ip address and NAS title in with no results

Hi @Jake_Sager ----- Thank you for touching base with me, very appreciated!

Moving forward, it sounds like RoonServer may not be running on the NAS. Can you please verify that it is indeed active? Furthermore, during your troubleshooting, have you allowed the mentioned Windows computer to temporarily act as you core, and if so was your iPad able to connect?


It sounds right that the Roon server may not be on. When i try to open it, there is no response. Here is a screen shot after i’ve selected the open option.

I have also not used the PC a core.

what procedures should i use to get the Roon Server up and running?

Hi Jake,
I guess you updated your QNAP to QTS 4.3.x and afterwards RoonServer did not work anymore. Please try to uninstall your current RoonServer on the QNAP (click the small arrow-down on the right side of the Open-Button and select remove).

Then reinstall the latest version of the qpkg (Get it here). It should pickup your previous database automatically.

An update for the qpkg was required here, as there was a change with the supplied system libraries of QTS 4.3

1 Like

That worked. Thanks you for the help.

1 Like