I cannot remove or edit a network share

Roon Core Machine

Intel NUC10 i7 running ROCK

Networking Gear & Setup Details


Connected Audio Devices

Synology NAS for storage

Number of Tracks in Library


Description of Issue

I have changed my SMB password on my NAS and Roon cannot connect to the drive - as expected.

It seems there is not way to change the password. I have tried the following:

  1. Tried connect to the same drive with new credentials - didn’t work
  2. Try to delete the network share and re-create - I cannot as there is no option

Connectivity seems fine as I can connect to another network share on the NAS (and have the option to remove it).

I have attached an image showing that there is no option to delete the the drive.

Any assistance would be appreciated.

I had this happen with a windows share once , I cant remember what I did to get rid of it in the end. I think I had recreate the share as it was, I could then remove it from Roon, then remove it from Windows.

As I understand you want to remove the folder media? Shared folders can only be removed in your Nas I think. Not an expert but had this once long time ago. What if you restart your Nas?

Thanks for the quick responses, very grateful.

After a bit more troubleshooting a reboot of the ROCK server fixed the issue. The “X” then appeared and I was then able to remove the reference and re-create.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.