I can't add some Qobuz albums or tracks to my library

Roon Core Machine

Nom de l’appareil DESKTOP-O12187P
Processeur Intel(R) Core™ i5-7200U CPU @ 2.50GHz 2.71 GHz
Mémoire RAM installée 16,0 Go

|Type du système|Système d’exploitation 64 bits, processeur x64|

Networking Gear & Setup Details

SSID : Livebox-
Protocole : Wi-Fi 4 (802.11n)
Type de sécurité : WPA2 - Personnel
Bande passante réseau : 5 GHz
Canal réseau : 100
Vitesse de connexion (Réception/Transmission) : 300/300 (Mbps)

|Serveurs DNS IPv4 :||
|Fabricant :|Intel Corporation|
|Description :|Intel(R) Centrino(R) Advanced-N 6205|
|Version du pilote :||

Connected Audio Devices

Number of Tracks in Library


Description of Issue


It does not happen all the time, but It happens with this albulm for example :slight_smile:

Instead of having the favorite icon, the circle keeps turning as if it cannot link with Qobuz database. It worked well with other albums and sometimes not.

What is the issue ? How can I upload my logs, if needed?
Thank you

Happens to me some times.

When it happens, I restart the core or remote and the album appears in my library. If it does not, try adding it then.

Sometimes I also find that although the icon keeps spinning, the album is added to my library. Do make sure it’s not already there.

No idea why it happens but know it’s been discussed on here many times.

If none of the above work for you, add it to your Qobuz library via its native app and then force sync Roon.

1 Like

Thank you; I did realise that yesterday. I assume no software is perfect then…

You’re welcome. I take it it worked?

Yes, your answer helped me mitigate the problem. Thank you.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.