I can't control the volume with Topping d10s [Resolved - use WASAPI and exclusive mode]

I just connected the Topping D10s to the pc and to the active speakers. I can’t get Roon to take control of the volume despite trying to play around with the settings. Windows 10 also keeps the volume constant and nothing happens if I turn it up or down. Only from the application that made me install on Windows together with the drivers from the parent company website can I set the volume. I would like to manage everything from Roon. Where am I wrong?

You can’t as it does not allow control of its hardware mixer via apps. Roon can’t change how your DAC works. Most DACs dont allow this only Roon Tested ones tend to and even then most of those don’t always. If you want Roon to control it you will need to use Roons DSP volume I am afraid.

I have a D10s attached to my Windows PC and, after dowloading the Drivers from the Topping website, I’m able to control the volume via Roon. Have you set the Volume control to “Device Volume”?


Hey @Vale_Ricci

Our good friend @SukieInTheGraveyard has found a fix for what you’re seeing on his Topping. Can you give his suggestion a go and see if that works for you as well?

Please let us know your results, thanks! :v:

1 Like

Nicely corrected.

1 Like

I will do further tests. I got the idea that it is impossible to control the volume since Windows does not do it either but if you tell me that you have succeeded I have to spend more time on it.

1 Like

I’ve had a D70 for some time and one characteristic is that I’ve never been able to bring the device volume under Roon control. The only way was to set it to DSP volume which of course isn’t bit perfect unless at full volume. That is using ROCK though which can make a difference.

It works with device volume on the USB end of a ROCK, with a Topping D10 (not S, but likely the same USBimplementation).
Please use WASAPI and exclusive mode, i don’t think ASIO drivers will do the trick.

Now it works! I use WASAPI in exclusive mode.

But now, for one track only it said “Device failed to initialize”. I don’t know why.

1 Like

Thank you for following up with us @Vale_Ricci to confirm that @Mikael_Ollars advice worked for you! Props @Mikael_Ollars for the assist and for your expertise - much appreciated!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.