I cant Login to Tidal from roon

If I try to log in I get this screen:

I have rebooted, deleted the TIDAL registry entries in the Database but still no joy. I have changed the DNS servers in my router to & Still the same result!

I can log in and stream tidal from my PC using the PC app as well as the web-based streamer so I know the account is fine.

Any ideas?

Restart the core system? Or just the remote?

Sorry, tried that multiple times :pensive:

Hi @Matthew_Carter,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Please try the following and let me know if this yields any changes:

  • Stop RoonServer on your Core
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

HI Dylan

Thanks for your prompt response.

I have fixed it by changing the IP to Static and manually changing the DNS from the local gateway to

I did this by logging into the ROCK via a browser and changing it.

No need for a reboot, worked straight away. Was probably the router not handling the DNS requests correctly. You may be able to fix this by pinging the router for DNS updates frequently…

Thanks again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.