I can't set up Roon Server on Synology NAS

Core Machine (Operating system/System info/Roon build number)

I am trying to install Chris Rieke’s spk file, to set up my Synology NAS as the Roon Core.
It is a Synology DS214se, total physical memory 256 MB (oh oh…) DSM 6.2.2-24922 Update 3

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

The Synology is connected via ethernet cable to my PC. I use the PC to reach the NAS.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Nothing yet. For now I first set up the Roon Core on the PC and used the PC as media player. That worked fine. Next step will be to to use either my Sonos or other DAC/streamer to send the music to amplifier and speakers. Anyway, I don’t really like the Roon Core on the PC, because if the PC is switched off, so is the Core. That is why I want to set up the Core on the Synology, it is never off.

Description Of Issue

Following Chris Rieke’s set up and download file, I can’t continue after manually installing the package, because my Synology tells me “This package is not supported on the platform of DiskStation or is incompatible with current DMS version”. I was trying to install the RoonServer_Synology_x86_64_2018-03-07.spk
End of the line. (I hope Chris nonetheless enjoys the coffee I donated)
Could not find this in the topic, sorry if I missed earlier discussion on this problem, I searched but too many options.
Thanks if anyone can advise how to solve this.

Probably post this under “Roon Software” instead of “Support”, would help. Also, we’ll need to know what version of the Synology NAS you have.



New user in need of @support

I had no problem on an 1813+ (2013 old Atom D2700 2meg ram)DSM 6.2.2-24922.
Did you create the folder with the proper name and capitalization?
Did you set the folder permissions?
Did you "adjust the trust-level settings in the Package Center Settings.

Click on the settings button in the package center and change the trust level to “Any publisher”."?

Thanks for helping. My answers to your questions:
Did you create the folder with the proper name and capitalization? (Yes I did)
Did you set the folder permissions? (No I did not: what exactly do I need to do?)
Did you "adjust the trust-level settings in the Package Center Settings. (I did not, but after your tip, I did and tried again to manually install the package: same result.)

Hi @Pieter_van_Blaricon,
I looked up the DS214se. According to the synology website, the DS214se is equipped with a Marvell Armada 370 88F6707 CPU, which is an ARM architecture. One requirement for Roon Server is an Intel compatible 64Bit cpu. Unfortunately the DS214se does not meet this requirement and the error message is not an error. It is simply not capable of running Roon Server due to a different cpu architecture. Sorry! :frowning_face:


OK, bummer, but thank you very much for taking the time to answer!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.