I have problems with Roon on my Grimm Audio MU1

Core Machine

Grimm Audio MU1, NUC8I3, Linux Tinycore 4.19.10 (64bit). Roon version 1.8 build 795.
SSD connected to core directly.
Synology NAS type RS815+.
All my music is stored on the Synology NAS; I’m not using a streaming service.

Network Details

Fully wired network.

Audio Devices

Grimm MU1 and Mola Mola Tambaqui DAC

Library Size

86,162 tracks.

Description of Issue

Music playback and connection between the Roon remote and Roon core stops regularly on my MU1 when playing music stored on a NAS in my local network. Especially when switching between tracks.

Playing files from a local harddisk connected to the core does not give problems. A network specialist has checked out my network and found no problems in the setup. I have tried adding a single folder in the storage settings which resulted in less crashes but not none.

Here are some timestamps of the crashes that occured: May 25 (in afternoon, during testing) and May 26 21.15 and 22.38. Sidenote: the internal time of the MU1 is GMT, these timestamps are GMT+2.

I have had contact with Justin from Grimm Audio, we have reset the database and did a clean setup which worked until we added the NAS storage. After that we have put back a backup of the regular database. He also checked the logs and it seems that the Roon core crashes on reading tracks from the NAS.


Hi, have you tried logging into the NAS and monitoring resource use (CPU/memory/network) whilst streaming music via Roon?

Has your music library been fully indexed by Roon? If Roon is still indexing, it requires a significant amount of resource.

If indexing is complete and everything works fine with a locally attached drive, then it suggests a network/NAS resource issue.

Can you give a description/diagram of your network layout?

Has your music library been fully indexed by Roon? If Roon is still indexing, it requires a significant amount of resource.

Yes, especially when I only added 1 folder from the NAS to Roon it was indexed quite quickly. Even if it was still indexing it shouldn’t crash.

If indexing is complete and everything works fine with a locally attached drive, then it suggests a network/NAS resource issue.

A network issue has been excluded by a network specialist who came over to check the network.

Can you give a description/diagram of your network layout?

A fully wired network. Modem: Connectbox Giga. Synology NAS wired via Netgear Prosafe GS108 switch, Grimm MU1 wired via Silent Angel Bonn N8 switch

Have you looked at NAS resource use?

Are the Netgear and Silent Angel both connected directly to your Modem, or is the Silent Angel connected to the Netgear?

Have you tried running things with the Grimm connected to the Netgear rather than via the Silent Angel?

Have you checked all of your cables to make sure all 8 cores are working so that you have Gbit rather than 100Mbit?

1 Like

@support, I have the feeling someone needs to take a serious look at the logs. The roon core crashes, this should never be caused by a network misconfiguration. It has been 3 days without even a reply from the official support team.

In order to review the logs, three additional timestamps of recent crashes of the roon core on June 1: 22.19, 22.29 and 22.43 during 45 minutes of streaming files from the Synology NAS. Sidenote: the internal time of the MU1 is GMT, these timestamps are GMT+2.

Hey @Gregor_Bertens,

Thank you for getting in touch and letting us know of the issue you ran into. I am sorry about the trouble and about the fact that it took us this long to get back to you :pleading_face:

I appreciate you engaging on our community and making efforts to resolve this, before we even got a chance to take a look.

I’ve moved your thread into our technical team’s queue. They will follow up as soon as possible :pray:

Thanks in advance for all the info :nerd_face:

Hey @Gregor_Bertens, would you mind following the directions found here and sending us a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

Hi Kevin, thanks for reaching out.
Here is the link to the logfiles:


Password: Gregor1@

Hope this will be helpful in order to find the origin of the problem and a solution to solve it.

Many thanks in advance!

Hey Gregor, thanks for passing those on. I took a look and it doesn’t look like there are any crashes, just lots and lots of network errors that lead to disconnections.

@Graeme_Finlayson is on the right track here – would you mind answering the questions he asked? These two in particular:

The answers to these questions will really help us to narrow things down, thanks!

Hey Kevin,

Thanks. To answer both questions of Graeme:

Yes, both the Netgear and Silent Angel are both directly connected to my modem. The Synology NAS is connected to the network via the Netgear switch and the Grimm MU-1 is connected to the Silent Angel.

No, I have not tried yet to run things with the Grimm connected to the Netgear but I can try to replace the Silent Angel by a (second) Netgear switch. However, the Silent Angel was explicitly advised for sonic reasons by my audio dealer and is 10 times as expensive as the Netgear…

Problems are mostly occurring at the moment new tracks are being buffered from the NAS while streaming music from the NAS. In a number of cases, though not always, the connection is lost and after that it takes a while (appr. 30-40 seconds) until the connection is restored. In most cases I can continue to play the track afterwards from the moment the connection was lost, sometimes however it remains silent in first instance and I have to pause first in order to be continue playing.

Hope these answers help to narrow things down step by step.

Thanks a bunch, this helps a lot!

If you don’t mind, let’s start by removing the Silent Angel from the equation and connecting your Grimm to your Netgear switch. Definitely not suggesting you keep it this way forever, but it does help to narrow things down.

Hi Gregor, not wishing to open a can of worms, but “audiophile” network switches have been discussed to death on here. There’s no objective proof they work.

In fact, there is objective evidence that they don’t work:

Your hi-fi dealer has a big incentive to empty your pockets (so that he can line his own)…

Many, many issues that users experience with Roon boil down to network topology/implementation.

I’ve had zero issues with Roon - however, I do have one of the most uncompromising network setups that it is possible to achieve in a home.

It’s built using relatively low cost, second-hand, enterprise-grade hardware with a high-bandwidth fibre backbone linking the switches to the enterprise NAS, which amongst other things, runs the Roon core. Everything that can possibly be connected by a cable has its own Cat6 UTP cable connected back to a 1Gbit port on one of the two network switches. I use wi-fi for wireless only devices and one or two other devices to which it is not feasible to run a cable.

I have no “audiophile” grade network components or cables - just high quality industrial/enterprise grade stuff like that used in businesses and data centres all over the globe.

So far, it has never let me down.

1 Like

Hi Kevin,

I did some testing with the Grimm connected to a Netgear switch (instead of the Silent Angel) by a regular network cable. At first testing the number of disconnections seemed to be less than normal (2 times in 90 minutes) but during a second testing batch yesterday, the number of network errors/disconnections were (unfortunately) same as normal. My conclusion: the Silent Angel switch nor the cable connecting the switch to the Grimm are the origin of cause of the problem.

So we have to look further is order to find the cause of the problem. Next step appears to be a temporarily switch of the Grimm MU1 by another model. For this we already reached out to my hifi dealer.

1 Like

Hi @Gregor_Bertens

Did switching the Grimm out work for you?

Hi Dylan, thank you for reaching out. Unfortunately, switching the Grimm for another Grimm MU1 didn’t work out. Playing music from a built in SSD, SSD via USB or Qobuz all worked very fine, only music streaming from my Synology NAS still often leads to a ‘lost connection’. When it occurs (appr. 3-4 times in 30 minutes) mostly within the first 20 seconds after a new track has started.

We have checked everything in the meantime: the network, the switches, the NAS, the Grimm MU1 (my MU1 was checked by Grimm). Latest thinking of Grimm is that the problem is caused by the combination of some Synology NAS models (mine is RS815+) with Roon is not properly working. More users seem to face the same problems (like Media from NAS loading slowly - #21 by noris). Until now no solution has been found (as far as I can see).

Hi Gregor, sorry to hear you are still experiencing problems with your NAS. What is the drive configuration? The RS815+ is a 4-bay, yes? Which drives are installed and how are they set up? RAID 0,5,6,10, Synology Hybrid RAID?

Looking back in the thread, a local HDD connected to the core worked without issue. This tends to suggest a bandwidth/latency issue when serving files from the NAS. Roon will pull very hard on your music file source to buffer tracks. It sounds like it’s running out of bandwidth…

Hi Graeme, yes the RS815+ is a 4 bay with 4 8TB Western Digital drives (WD Red Plus 3.5’ NAS HDD), configured in Synology Hybrid RAID.

And yes, a local built in 4TB SSD is working without issues, just as 2TB SSD’s connected via USB to the Core. Problems are only happening in case files are streamed from the NAS.

Hi Gregor, have you looked at the CPU and network utilisation widgets within DSM when these issues occur? They should give you an idea whether Roon is hogging any resources while pulling files from your NAS. Also, have you checked/tested all of your cables to make sure all 8 cores have correct orientation/continuity? I once had my broadband speed drop from >300Mb/s to <100Mb/s because of a faulty cable. The interface dropped from GbE to 100baseT.