I Nucleus 2.0 update -

Roon Core Machine

Nucleus 1.8

Networking Gear & Setup Details

iPad Pro IOS 15.6
Roon 1.8 App

Connected Audio Devices

Number of Tracks in Library

Description of Issue l


When I got the update available notice and tried to update to 2.0 the core hung up and would not complete. I rebooted the core and then couldn’t connect to the Roon 2.0 app. I had to roll back to Roon 1.8. I am now running on 1.8 but it doesn’t give me the option to update to 2.0 in nucleus.

1 Like

You can try this -

But -

I went to the Roon 1.8 to 2.0 migration FAQ and completed all the steps, the core did not update. I rolled back the remote to 1.8 stopped the core and reconnected . I even tried relaunching the core to see if tit would update? It say’s I am running the latest version of the core 1.8. What now?

Yep, those procedures don’t work for many people. Didn’t work for me.

Tagging @support.

Tried today also, still not working

I’m running a Nucleus as the Core on an Orbi mesh WiFi system with multiple apps but mainly one of my MacBook Pro 2021 model running macOS Monterey 12.6

I’ve been able to access the “Data” drive by finding the Nucleus on the network with its IP address but to another poster’s point, there is no “share” folder, only Codecs, MachineSettings, RAATServer, ROONGoer, RoonOS, RoonServer, Storage, and a ReadMe file.

Like another poster I created a folder called “share” directly on data and then a subfolder called branches and downloaded the roon_2-0 file and copied it and renamed it roon and then reinstalled the operating system. I did this several times and it did not work. I even tried moving branches directly to the data folder but that didn’t work either.

I’m at a loss. I deleted the Roon 2.0 apps and downloaded the now legacy Roon 1.8 apps again.

If anyone has any other ideas to upgrade the Nucleus to 2.0 let me know.

You’re misreading the instructions. It says to create a folder called branches in the /Data share - not create a folder called branches in the folder /Data/share - as you say, there is no folder called share

I tried this as well - last night and today. Nucleus version still reads 1.8

Any other thoughts?

Saw a post where it was said to keep your Roon Remote 2.0 open when reinstalling the Nucleus software. Don’t know whether this will help…

That’s what I originally tried. It didn’t work, at least for me.

Then there’s this -

So, one is supposed to know this trick to effectively use the update procedure? This is what makes people crazy.

Here is what the folder tree looks like on my machine:

See my posts here and here, which may possibly help.

In summary, although the Roon 1.8 <-> 2.0 Migration FAQ states clearly (in the context of a downgrade from 2.0 to 1.8 legacy):

You will need to install the Roon 1.8 legacy app on a Roon Remote/iOS device first before being able to take the downgrade.

what it does not say explicitly is that the only way Roon will know you have done that is by keeping open the version 1.8 legacy remote app when downgrading the Nucleus. I rather assume the same applies to anyone attempting to upgrade from 1.8 to 2.0. In other words, for those users, ensure you have the version 2.0 remote app open (i.e. attempting to connect to the Nucleus) when running the upgrade of the Nucleus.


Hi @Richard_Comer ,

It looks like you were on production1x track for your Nucleus. I’ve flipped the switch to get your Nucleus back on the 2.0 track, can you please create a Backup of your Roon database just in case and then perform an OS reinstall via the Web UI? This should then get you back to Roon v2.0.

Thanks your the latest information. I now have 2.0 installed,

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.