I/O Failure in about 10% of my tracks

Hello. I am having an I/O failure in about 10% of my files. Most of the time, it looks like it’s picking up a couple songs per album and not the others so many of my albums are incomplete. My Logitech Media Server does not have any issues.

Version of Roon: Windows 64 bit, 1.3 build 262
OS: Windows 10
Basic information: HP Pavilion dm4 Laptop w/8 GB of Ram.
Where your music is stored: QNAP NAS 219P+
Let us know your collection size: it’s all over the map. some files are very small, some very large. my collection is mp3 320k to CD quality flac (44/16) to hi hes flac (192/24)
Network info: all wired (laptop wired, NAS wired) I use this Laptop as a server.

I’ve tried the whole shut down and restart core server but that didn’t work. I really don’t want to delete the files and re put them there as that will cause my Logitech media server to look at these files differently, but if you guys say I need to do that, I guess I will…

any other troubleshooting ideas?

I would do a spot check with mp3val or audiotester to figure out whether files are corrupt. Also check your drive for errors.
If files are corrupt - we can’t do nothing about that, if the drive is failing - you can try to move them.

My Logitech media server plays all these files just fine. If they were corrupt, Logitech media server wouldn’t play them in their entirety. I did check th drives and they are error free.

Plus I have a weekly backup service that runs at 2am on Wednesday that checks all the files and then backs them up. There were no issues in running the backup service this morning. These drives also get virus checked weekly.

Have you tried to check the files with one of the suggested apps ? Also, where do you get the info about I/O failures ? Is this ‘Skipped Files’ section in Roon ?


1 Like

yes that is where I get the info “skipped files” section in roon. I have them in a spreadsheet and I went through and played each one last night via Logitech media server. I haven’t used the programs you sent me and if it’s a necessary step, then I’ll do it. if they were corrupted my Logitech media server would not be able to play them.

so all the files had the error “unable to open decoder” when putting it through audiotester. but yet they play on Logitech media Server and they play on my computer and on the ipad via a file browser when I just double click on them. I am just going to delete them and recopy them to see if that works also…

That’s a good test to try. Let us know about the results.

yea that didn’t work. now those files don’t play on my pc either. but they do play via Logitech media server and they play via my ipad. but not the pc that roon core is installed on. the mp3 tool you gave me doesn’t work because it says the files are too large. in audiotester I got the error “unable to open codec”

most of these I purchased from HD Tracks so I reached out to support to have them allow me to download them again. I can’t imagine anything happened to the files as the ipad and Logitech media server plays them fine, but who knows. unless you guys have any other ideas, once I get the files from them, I will download them and replace the ones I have with the new ones.

on groove music (windows 10 app), I get the error 0x8004005 when trying to play all those files but all the other ones play.

sorry - error 0x80004005

ok so that didn’t work either. as another test, I put the files local to my computer as well, the computer that is running the roon core. no problem grabbing the files off the local computer – but when that exact same file is on my NAS, Roon only picks up 90% of them. any ideas would be greatly appreciated.

Can you upload an affected file to Dropbox or similar and PM me a link? We can try to reproduce the issue here @Darien_Hallagan.