I/O issue now where there was none

Roon Core Machine

Nucleus +
Files on NAS

Networking Gear & Setup Details

Eero…all connected no wifi

Connected Audio Devices

Library Size


Description of Issue

when I checked last week there were no skipped files in library. Now there are 6 due to “I/O” issue
I have changed anything
Any thoughts?

First step would be to check the files and see if they have become corrupt in some way. Has there been any attempt to play them in Roon in recent history?

No attempt
Thank you

Hi @thomas_clark1, are these files new additions to your library or are they files that have been there for a while?

Have been there for at least a year
As mentioned never appeared on the list until recently
Work fine on other music players
Love Roon Dylan but damn it’s quirky

Any change after a reboot of the NAS + Nucleus? If not, can you send this album to me in a PM? I’ll take a closer look.

1 Like

Thank u
Funny due to my ongoing nucleus issues NAS and Nucleus are rebooted frequently

Nice of you to offer to look at the album

It’s about 1.1 gb…

What’s best way to get that to you?

There are like 6 of them but would be interested in what u find out about at least one

Hey @thomas_clark1,

Can you please upload the the albums to Dropbox, Google Drive or a similar service and post a link here? Please be sure to turn on “sharing by link”, instructions on how to do so for Dropbox can be found here and for Google Drive can be found here.

If you don’t have one, please, let us know and we’ll share an alternate solution :nerd_face:

here you go…appreciate your help

Hey @thomas_clark1,

Thanks a whole lot for sharing these. They are now with our technical team - they’ll take a look and follow up as soon as they can :nerd_face:

Stay tuned :pray:

Any info available on these files?
Thank you

Hi Thomas, I’m sorry the QA team has been busy with some testing projects but I hope to have more information for you very soon. I"ll be in touch ASAP.

1 Like

Sent some files to u guys to be analyzed some time ago.
Any word on them?

Hey @thomas_clark1,

Thank you so much for including that information and keeping in touch :pray:

After investigation, we’d be grateful if you could try this:

  • Make a copy of these files outside of the watched folder
  • Delete the current ones
  • Move the copy back into the watched folder

Does this help?

If the issue persists, could you please immediately after grab a set of logs and send them our way? Please, write down the date and time too.

Thanks a bunch :pray:

Think.ive tried this bit will again and let you know

I did as you suggested but the files still have a problem with Roon…they play fine on other players.
I had sent some of the files to you awhile back to be looked at…has anything come of that?
thank you

@thomas_clark1 it might also be worth adding in an additional step, just after you delete the current files, i.e. Settings → Library → Clean up library → Clean up ‘n’ deleted files

This will remove all reference to these files from Roon’s database prior to them being re-added. This may well make no difference, but I figured it’s worth a try.

1 Like

Thanks @DaveN! I think that’s a brilliant suggestion :blush:

What were the results of the analysis of the files I uploaded to you some weeks ago?

Hey @thomas_clark1,

I am so sorry for failing to mention this in my previous message: our team has tested the files you’ve shared and they worked perfectly in Roon on our end. This being the case, it is very likely that some environmental factors are at play.

Did you get a chance to clean up the library, and try this?

  • Make a copy of these files outside of the watched folder
  • Delete the current ones
  • Move the copy back into the watched folder
1 Like