I think my NUC has died!

Roon Core Machine

Intel NUC 8 running ROCK with 2TB internal storage for music library. Hard wired to Netgear router

Cambridge Audio 851N - Hard wired and WiFi to router

All has been working great since initial setup around 2 years ago… until yesterday.

I fired up Roon on my remote (Kindle Fire) and was told it was having trouble connecting to CORE and would I like to select another CORE. I checked the router and the indicator light for the port connected to the NUC is now orange instead of the normal white. I tried connecting to \rock\ on my laptop on the same network and it could not find it. I tried power cycling the NUC - no change. I tried power cycling the router - no change. I tired the NUC in a different port on the router, no change. I changed all the {cat 5) cables - no change. I tried connecting the NUC via WiFi to the 851N and was again told it could not find the CORE. Finally i tried moving the NUC over to the 851N and connecting it directly to the 851N via the Ethernet port. Again, no change.

So I’m guessing that my NUC is sick but my computer skills are very limited.

My questions:

  1. Is there anything else I can/should try before condemning mu NUC?
  2. If the NUC is faulty can it be repaired and if so any idea where I can send it for repair (I’m located in central Californa.)
  3. If it can’t be fixed what is the best replacement NUC (on a budget.) I am not a power user. I have around 50,000 tracks, one one end point and no real DSP but I would like to play with DSP later.
  4. If I buy a new NUC and i use the memory, SSD drive and hard drive from my current NUC?
  5. Can you send me the link to how to set up the NUC with ROCK, as I said my computer skills are very limited and its been a long time since I set up my current NUC/ROCK.

Sorry for the long winded message and all the questions. But its been 24 hours and I am missing music already. :sunglasses:

Any advice, help, suggestions VERY gratefully received.

Thank you


Do you have a screen and an HDMI cable to connect it to the NUC? If you do, it’s worth trying to see (take and share here a pic with your phone) what the NUC displays there, if anything, as it powers up.

1 Like

Ok. I can do that. I’ll post picture tomorrow. Thank you

I had the internal network card fail in a NUC. Fix was to use a USB Ethernet adapter plugged into the NUC USB 3 port. Might be worth a try.

Hi Fernando,

So I connected the NUC to my TV via HDMI (the same one I originally used when first setting up the NUC) and I am not getting anything on the screen. The power light comes on on the NUC but nothing on screen.


Seems pretty dead, unfortunately. I have a NUC in that state myself, but fortunately I had a backup server and I’ve not tried yet to revive the NUC. Others here might have suggestions on whether replacing DRAM (for example) might be a good starting point.

Thanks Fernando

Advice, suggestions from anyone gratefully received.


Have you tried contacting Intel support? They’re quick, professional and friendly, and can probably help you out. They’ve already sent me two NUC8 replacements under warranty and I’m still working with them to resolve the issues I’m experiencing. I recommend their support, but I’m not inclined to ever buy a NUC again.

Hi Ian,

  • Unplug the power cable, hold the power button pressed for a minute to discharge the device completely and retry.
  • As Fernando suggested, RAM might be the culprit. Remove the RAM modules and try if you get output on the screen.
  • Remove the m.2

I didn’t even know there was such a thing as Intel Support!!1 I’ll give them a try - thank you. Out of curiosity, what do you use now in place of a NUC?

OK - I will try this and update afterwards.

Thank you


I still have my NUC - I have a pending ticket here on the forums for it :slight_smile: But I won’t consider buying another in the future. I’ve by now spents hours and of hours trying to get it to work the way I want to use it (something that should be plug & play), both on Linux and Windows, but it’s been a pain and all the issues still aren’t resolved.

A friend of mine is perfectly happy with her Zotac mini pc: https://www.zotac.com/. It does all the stuff I want my NUC to do and it’s silent out of the box :slight_smile:


Thank you - I hope it won’t come to buying a new unit, but good to get recommendations just in case

if the nuc is still powering on it could be something simple as a dead ssd? maybe try swapping out the ssd

Thank you James - I’ll try that as well.

Power down the NUC.

Remove all drives from the NUC, especially the m.2 boot SSD.

Post the brand, model, and capacity of the m.2 boot SSD.

Without the drives, try powering up the NUC, check if anything shows on HDMI.

If it powers up without the m.2 SSD, your m.2 SSD is dead.

If it still does not power up, power down the NUC and carefully reseat the RAM.

… remember to also be patient. When in a failed state they can sometimes take up to 5 mins to boot to POST or the OS screen. Those NUC boards are tricky coves.

Also remember whilst doing all this to follow anti static precautions as best you can e.g. no skipping across deep shag pile nylon carpets or stroking the cat before working on the PCB or components. Try and touch a grounded radiator or water faucet before handling components.

Also try booting from a live image. One I like is Pop-OS from System76 which I use to run my Roon Core in a VM on my file server. It is possible your boot image was dinged and may just need to be replaced. m.2 media is usually pretty reliable. Don’t boot from a thumb drive other than for installations and testing.

See the hardware troubleshooting procedures at System76 Support
System76 Meerkat machines are private labeled NUCS.

Thank you David - but I am afraid I don;t know what that means!! Like I said I am computer illiterate. :grinning:

I assume you’ve attempted the traditional superstitious behaviors of reinserting the memory, reinserting the disks, etc. Sometimes a card wiggles loose. Less an issue than with PDP-11s of the '70s and '80s. Anyway, it is worth a shot. Low risk but also low probability of fixing the beast.

Check that the NUC and its memory are happy

Test the memory. Memtest86+ is a stand alone memory checker that you transfer to FLASH with Etcher, boot from FLASH, and follow the prompts. Let it run over night. There are likely options to stop on error (good for the first run) or to press on logging errors which is useful if soft-errors are occurring. Memtest ignores the disks.


Replace any memory that memtest indicates is faulty. ROCK has no memory error detection or correction. It needs perfect memory.

Next, I’d try the ROONLABS recovery procedures. They will preserve your ROON database.

The recovery procedure is very similar to the ROCK installation procedures you followed during commissioning of your NUC. You’ll take the recovery option rather than the fresh installation option.

The NUC roon Nucleus installation procedure is here and looks easy to follow

I use Balena Etcher quite a bit to transfer system images from a file to FLASH media. The Roon guide covers use of Etcher.

So you’ll transfer ROCK to FLASH. Insert the FLASH key in a USB slot and boot from that media following the NUC procedure to boot an alternate image. There’s really nothing new here.

The ROCK image should come up just as before. Select the option to make an update installation to m.2 boot volume keeping database. Be careful to pick the recovery installation or you’ll loose your stars, hearts, and play counts. And your Qobuz credentials. And your local media library records.

If that doesn’t work, switch to the more detailed System76 instructions that will take you through hardware diagnosis to determine what is broke. The System76 POP_OS installation is very similar but will give you a full POP_OS Linux environment and all of the System76 troubleshooting tools.

System76 Meerkats are private labeled Intel NUCS. The link above covers live disk creation, startup procedures, and system testing procedures. I like the folks at System76 and next non-Apple computer will be one of theirs.

My Roon Core runs on POP_OS in a VM on our TrueNAS file server. We provide some POP_OS support funds. The ROON updater keeps ROON Core up to date. I have to update the OS by hand every now and again.

If you want, you can install regular Linux ROON core or replace POP_OS with ROCK. Since there is no ECC in the NUC, there is no advantage either way. POP_OS will support ECC when it is present.

ECC is error correcting coding, a technique that detects and repairs all single bit memory errors and detects most multibit errors. Considered essential for 24/7 operation. System76 AMD desktops can be configured with ECC.

1 Like