"Identify Album" Not Working [Fixed]

Roon Core Machine

Mac Mini, late 2021, 2.5 GHZ dual core i5, 16GB RAM, SSD, Catalina 10.15.7

Networking Gear & Setup Details

Ethernet, working perfectly otherwise

Connected Audio Devices

Macbook Pro 2020, M1, 8GB RAM, Big Sur version 11.6

Number of Tracks in Library

3,707 artists, 14,777 albums, 186,686 tracks

Description of Issue

When trying to identify an album, it takes much longe than usual to search, then nothing at all comes up. I’ve tried using just the artist and album name, just the artist, just the album, etc… No search results show up. Everything else is working fine. This happens directly on the Roon Core (Mac Mini) as well as the Macbook Pro and an iPad that I use as a remote.

Any help would be appreciated!


I am having the same problem. I think it started yesterday. I rebooted both the router and the computer and the problem persisted.

Same here. Won’t even identify previously identified albums

Same here. The issue started yesterday. I’m guessing this is a service issue, and not a software or network issue.

Same here in Germany. Yesterday evening started. It’s not possible to identify albums.
No matter if the music is stored on the NAS or from Tidal, Qobuz in the library no identification is possible. Example: Dire Straits “Brothter in Arms” no result.

Hi, thank you for your reports. Unfortunately, it appears that we have a problem in one of our services. The team is working on a solution at them moment. This thread will be updated as soon as we have a fix.

Apologies for troubles.


Our team was able to identify and fix this issue. This functionality should be working as expected. @Jan_Terje_Hansen , @Andreas_Hartwig , @Russ_Radcliffe , @Pacomo , @Joseph_Squires , thank you for letting us know about this issue.



Now it works again without errors. Thank you for the quick solution of the problem. Greetings from Germany, Hannover

Thanks for the quick response. All good now.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.