Identifying metadata stalled

Roon Core Machine

Roon Nucleus with no additional internal storage and latest software. Purchased a few weeks ago.

Networking Gear & Setup Details

Third Floor: The Roon Nucleus is connected by CAT6 Ethernet cable to a Luxul 12-port/8 PoE+ Gigabit Managed Switch model AMS-1208P. I have a M1 Mac Mini acting as a Roon Remote (2020, 8 GB, OS Monterey version 12.2.1) connected by ethernet to the switch.

Ground Floor: The managed switch is connected by CAT6 Ethernet cable to a Luxul 26-port/24 PoE+ Gigabit Managed Switch model AMS-2624P. This switch is plugged by CAT6 cable to a Xfinity xFI Gateway Router model name CGM4331COM by vendor Technicolor.

Connected Audio Devices

The 2 USB ports on the back of the Nucleus are used by my Amicool USB External DVD Drive (Amazon) and a Seagate 5 TB external desktop HDD model SRD0NF2.

The additional Roon remotes for DACs, Amps and Sonos speakers are an iPhone 13 Max and a 2019 12.9 inch iPad.

Number of Tracks in Library

6000+ tracks

Description of Issue

I restored from a backup. None of my added tracks have been identified in over 8 hours. I use my iPhone as a remote. Each time I’m using the app on the iPhone, the app crashes in less than 1 minute.

This is the error message I receive in Roon:

Sounds like a network problem
Can you get to the nucleus web page?

Have you tried rebooting the server?

Yes. I can get to that page. I’ve rebooted as well.

Have you tried rebooting the modem and router. This error normally points to a missed connection to “Roon cloud” on start up.

Try a total cold start. Shut down, plugs out, brew tea. Then start each component in turn waiting until each one has started before starting the next.

Worth a try , especially if you like tea :sunglasses:

The metadata improver pauses because the Nucleus thinks there is still the old login from which this backup should be created.

With only 6000 titles I would start completely from scratch.

Was a lot of time needed during the first import? I manage up to 400000 titles in one day. With very bad metadata it can also take weeks.

There should always be a title, artist, album, tracknumber, date so that it goes fast.

Thank you. I believe the initial import took a short time, maybe a couple of hours. How do you recommend starting from scratch?

An additional complication is the fact that during the time that the Nucleus was being repaired by Roon because of a faulty SSD, I intermittently used two different laptops as my Roon Core. This recent attempt to restore from a backup occurred after I receive the repaired Nucleus two days ago. I wonder if there is still data on those PCs that is interfering with this import.

When I set up a second or third PC also as a core or server, there is always this metadata pause until I disable the other core. The current core/server asks for this deactivation, but then there is still metadata pause until the next reboot/restart.

If the SSD was broken and there is a bad backup of it, there will continue to be problems, so I would have used the few hours to completely restart and re-read all data directly from the USB hard drive without a backup.

Before reading your message, I made the mistake of trying to reset the database and settings on the Nucleus’ web site. It seems to be taking far too long to complete.

I think you can get rid of the stuck USB disk under SETTINGS STORAGE first with REMOVE.

Under LIBRARY there is MAINTENANCE to clean up.

Now you are back to the beginning with an empty library and do ADD under STORAGE. If this problem persists, the health status of the USB hard disk is not ok.

I removed the Nucleus from the Ethernet switch and plugged it directly to the router. Some of the original software issues have resolved - the stalled metadata issue for instance.

Now, I have one new problem - the Nucleus doesn’t recognize any of my remotes or any other devices on my network. The only functioning “devices” are the two USB ports on the back of the Nucleus.

A persistent problem is that the iOS Roon app on my iPhone 13 Max crashes within 30 seconds of being opened. Strangely, the iPadOS app is stable and doesn’t crash. I’ve deleted and reinstalled the iPhone app a couple times with no luck.

All of my remotes can connect with the Nucleus. They just don’t populate in the Audio tab of settings in the Roon app. Any ideas about getting the Nucleus to recognize any of my devices so that they populate in the Audio tab of Roon Settings?

@nucleus support

If audio devices were not or incorrectly detected, has helped me only the restart (uninstall, delete all Roon/RAAT remnants in all folders…).

Unfortunately, Roon remembers what was already connected via which IP and occasionally comes into the skid, if in the current configuration no longer everything fits as before.

After I moved the Nucleus to the router, the software installed and settings were restored. Since none of my devices were seen in the Settings>Audio page of the Roon app, I moved the nucleus back to the managed switch. The devices reappeared.

Unfortunately, the iPhone iOS app keeps crashing after about 20-30 seconds of being open. Any advice?


Might not be the issue, but, Roon’s network faq has a section on managed switches you might want to review.

If you lose connections by moving the location of the device, then most likely there is a network setup issue.

1 Like

Thanks. After all the steps taken in this message thread, the system is running well with the managed switch connection. My only problem is the iOS app which crashes within second of opening on my phone. Luckily, I can compensate by using a PC, Mac or iPad as remotes.

Would you recommend that I check with my managed switch’s tech support to ask if there may be throttling of IP addresses?


Try fully uninstalling and re-installing the app on your phone. When prompted be sure you allow permission for Roon to find devices on your local network.

If that doesn’t work then the fault almost certainly lies within the configuration of your network. It could be related to your switch configuration or the setup of your Wi-Fi network(s). Roon’s remotes require multicast to be functioning in order to discover the core and we’ve found that many managed switch environments break this functionality by default.

Unfortunately, troubleshooting the configuration of your network is beyond the scope of what our support team is able to provide. I recommend that you contact your integrator to further troubleshoot your configuration.

This topic was automatically closed after 35 days. New replies are no longer allowed.