If not the Allo USBridge then what?

I bought the Allo Sparky/USBridge on 12/1/2017 and it has worked just fine running DietPi since then.


Since buying a Schitt Modi 3 DAC, I tried the Allo again. Works faultlessly with this, so it was obviously an issue with the USB implementation I had with the PS Audio Sprout 100 and either the old kernel in the Sparky or the Allo HAT.


I’m interested if you still have the bridge for sale.



Hi Greg

I may be looking to move my Allo on soon.


Okay, let me know.



Where are you based? I’m in the US and it had the 110v per supply.

I was thinking that I’d sell for about $120.

Has anyone compared their working USBridge output to that of a RPi 4 using the USB3 output?
Comparable? Any Audible difference?

… any findings in that regard would interest me as well

If not the Allo USBridge then what?

The upcoming Allo USBridge Signature… will be RPi based, the CM3 board according to this public thread discussion:


1 Like

Why would the USB3.0 port perform any differently than the USB2.0?
I dont think there any DACs/specifications that require or benefit from USB3.0 specs. i might very well be wrong though! :slight_smile:

First I hear of USBridge Signature, although I guess it was to be expected. I wonder if it will sound better than toslink to my RME ADI-2 DAC. Do you have any more information about it?

More info is scattered throughout that thread I linked above.


I think the USB bus on the RPi4 is better than on the RPi 3 - not shared with other things like ethernet. Stress think - can anyone confirm? If so then it should theoretically sound better


Absolutely Phil! My curiosity was rather why one would want to employ the USB3.0 ports on the Pi4 rather than the USB2.0 :thinking:
The Pi4 has got two USB2.0 and two USB3.0 available, so i was eager to find out if there was a sonic difference between the two port sets, or any other differences fior that matter.
Like i wrote, i am not aware of any USB Audio device which takes advantage of USB3.0 availability, but would like to know! :slight_smile:

Meant to reply to this long ago, then forgot. Responding now …

My statement was based on what I was made to feel ignorant about in other places (threads and forums); and adopted the belief for my own. ;). That being that USB 3’s superiority over 2’s is the power delivery potential, cleanliness of that power, adherence to the better defined standard by port manufacturer, and quality of the interconnect by cable manufacturers who must implement a higher quality cable to be compliant with the requirements of a much higher bandwidth interface.

So it is certainly not that the audio we listen to needs the bandwidth that USB 3 is capable of … but that software, hardware, and interconnects necessary to meet USB 3’s better defined and more taxing specification makes for a cleaner ‘better’ interface.

1 Like

Hans Beekhuyzen has recently posted a sensible explanation for why RPi4 may not sound as good despite USB 3 and separation from the network interface: https://www.youtube.com/watch?v=cjqEPyMr1zI&t=300s

But he doesn’t listen or measure? At least i didn’t see any cold fact behind those “explanations”.


Hi Mikael!
What DAC are you using with the USBridge? I am using a Directstream DAC and cant get DSD128 working with the GUI Image.


I (think) i have tried the USBridge with my Moon 430HAD (Native DSD256 with ASIOdrv), Audiobyte Black Dragon, Chord Hugo TT and Nagra HD DAC. These all do DSD128 with the USB Audio 2.0 spec, and i have never had issues with that, in conjunction with the USBridge. I did, however ditch the GUI OS rather quickly.
I etched the eMMC with DietPi and have been ”happy ever after”! :grimacing:

1 Like

In that video, I wish Hans had at least tried the USB ports on the RPi4.
I’m running Ropiee on a RPi3B+ that’s connected to a PS Audio Sprout 100 via USB. It sounds very good. Though sometimes when playing DSD64 or DSD128 I get intermittent pops. Using an iFi iPurifier didn’t help.
I briefly tried a Ropiee on a RPi4 and it seemed to work better - as far as the USB ports are concerned (I used the USB2 ports).

I think I need to give the RPi4 another try.