If Soft Shutdown = Watched folders "disconnect"


So I’ve been using my new Nucleus+ a couple of times.

I’m one of those customers that like to shutdown their appliances, if they are not in use.

I know RoonLabs say that Nucleus is meant to stay on, in other words.

This is what happens every time I do a Soft Shutdown (yes, I’m doing it correctly):

When I turn on the Nucleus, again, and open the Remote app (Google play Android), it welcomes me as if I haven’t imported any music. So I go to “Storage”, and my watched folders have the following message: This drive is not available. you can edit folder, because it might have been moved" you know, more or less in those words.

When I select: “…”, “rescan” option is not available, so the way to show my library again is, I have to select “edit”; “browse”; reselect the path of the watched folder, and save. At the point, it automatically tells me what has been imported (no importing happening at that moment), and it starts to scan the files in the watched folder. After that, the library is visible, again. It remembers the original import date.

I have my music in a self powered USB drive. The way I turn on my system: USB drive on; Nucleus+ on.
After experiencing this problem, I have tried:

Turning on the usb drive after turning on the Nucleus+.
Turning on the Nucleus+ (after a Soft shutdown), without turning off the USB drive.

Same outcome.

Is this normal/expected from Roon?


Hi @1c9e4,

What is the model of USB drive you’re using?

Thanks, Dylan

Manufacturer # HUH721212ALE600
On one of these:

By the way, just in case:

Man# is for the drive. (google search)
The link is for an empty external drive enclosure.

Hi @1c9e4,

I just wanted to let you know that our QA team is investigating this and I’ll update you as soon as I’ve received their feedback.

1 Like

Thank you for the update, Dylan.

A post was split to a new topic: Periodically when I try access my library I get the message saying that my library is empty

Hi, Dylan

Can you check if Roonlabs has found the source of the problem, please?


Hi @1c9e4,

Apologies for the delay here! I met with the team to discuss their findings. They’ve done some testing in our QA labs with a variety of setups and drives and our team has not been able to reproduce the same behavior that you’re seeing in any case, so we are hoping you might be able to provide some additional information about this issue.

To help us narrow things down a bit, our team is hoping you might be able to try reproducing this issue with another drive besides the OWC (we do not have this exact model in our QA labs). Does the same issue occur? If so, can you make a note of the time so we can check diagnostics for that drive as well?


1 Like

8:20pm 4/21/2020 turned on Nucleus+
8:21pm lauched the app on remote
8:24pm app asked to update. I selected view details. “Core” says: “An update is awaiting relaunch.” Below that, a link: “Click here to Relaunch”

p.s. - this isn’t the first time that (well, it is the first time today) Roon remote app has asked me to update, like above, when I turn on the Nucleus+, and there’s no library visible, like explained above in original post. I update it every time it asks me to.

8:30pm I click the link.

A message comes up: “The new version of Roon you installed, requires a database update. This may take longer than usual”.
But, it doesn’t take long at all. 2 seconds.

8:33pm added a new watched folder in “storage” to the 4GB exfat formatted flash drive, in the second usb of the Nucleus. 1 album imported. (you know, simple test).

8:38pm All watched folders on the OWC usb drive, are still showing the problem “this drive is not available. Check the drive or edit this folder if it’s been moved.”, as described in the original post above.

p.s. - I turned on this OWC drive at 8:20pm, and a few seconds after making it’s starting up noises, I turned on the Nucleus at 8:20pm)

8:48pm forced a rescan of watched folder called “All” only (no other folders, because I just want to test if it happens again after reboot) by selecting link “edit this folder” from “this drive is not available. Check the drive or edit this folder if it’s been moved.”, and browsing to the watched folder location, and selecting “save”. This triggers an automatic rescan of the already imported files. This is the way I deal with this problem for now, as explained in original post. After a short while, rescan finished fine, and Overview shows “added 32 days ago” for each album there, on this watched folder from OWC drive, which it was the original import date.

9:02pm Ok, the moment of truth. I will soft shutdown by selecting: setup>configure>clicking on Nucleus+'s IP>opening the red power button, in the opened tab>select “power off”>“Power off?” pop up, selecting “yes”. Then pop up reads"powering off", then “success”. Then I click “ok”, in pop up, and a few seconds later, the opened tab reads: “this site can’t be reached”. Then, I close tab.

9:10pm I close Roon app, by going to recently used apps area/opened apps area, and just swiping it upwards, so it disappears.

p.s. - now that I’m sounding like a total noob, I’ll use this moment to mention that a month ago, during the first couple of days of usage, I did a hard shutdown on the Nucleus+, one time, by holding the power button for a few seconds. Is there something I should do about this, now?. I just did it because the app was not responding. Later, I learned that by simply reinstalling the remote app, this not responding problem, could have been fixed. I haven’t much experience with mobile apps.

9:19pm Turned on the Nucleus+. I’ll give it a couple of minutes, just in case. Usb drives left untouched.

9:24pm Launched Roon remote app.

Sunnababeech. Well, it looks like the 1 album on the flash drive is recognized in the welcome area.
Yep, by going to “storage”, I can see the flash drive’s watched folder is alive. Can’t say the same about the OWC watched folder I force re-scanned, earlier. OWC watched folder is giving the same problem, again.

Dylan, can you have Roonlabs recommend some storage drives, please? I’ve been thinking of moving to SSD, because of the HDD’s in listening room clicks heard during music’s calmer passages… but those Samsung prices don’t look attractive, after spending way less on an HDD, with way more storage space.
Not sure if I should go internal, or external, either.

Damn it.

Please recommend from both, if they are both fine?


9:48pm Soft shutdown the Nucleus+.

Good night. :roll_eyes:

Hi @1c9e4,

We don’t have any specific recommendations for SSDs — As long as it meets the criteria outlined here it should work for you.

1 Like

Dylan, thanks for the link. That covers internal.
What if it’s external, I’d hate to buy something, and then it’s not compatible. Has Roonlabs provided a list of what USB drives work with Nucleus, or should I create a separate topic to ask the community?

Maybe Roonlabs can share what USB drives have worked for them, when Shutting down / powering up the Nucleus?


I use passports as well. But, dylan may be able to provide a more recent preference.

1 Like

Thanks, Daniel. I’ll look into those. I’ll also wait and see if Dylan has anything to share.


Hi @1c9e4,

For external drives we don’t have any specific recommendations either. As Danny mentioned in the Topic linked above by Daniel, WD My Passports are devices we’ve had success with, but any standard external USB drive should work for you.

1 Like

Ok, thanks, Dylan. I’ll research a little bit more about WD My Passports, and will probably get one, and report back before closing the thread.