iFi Bridge - A UPnP / DLNA app solution for playback on Roon


Thanks for your message, I will take a look into this matter and get back to you.

Kind regards,


I have tested this on our Pro iDSD and I was able to get 192/24 no problem, Are you trying to play PCM or MQA?


Playing throught roon via the ifi bridge to the devialet phantoms Flac 24/ 192 files are downsampled to 24/48. This is shown in the play path on roon but no DSP settings are doing this? Mqa just passes though as the phantoms are not mqa licensed.

The default settings for the ‘squeezeupnpbrdige’ is 48,000 KHz.
If you can find a config.xml file, there is an entry to change this up to 192000

I have the Bridge deployed to a RPi2, as a backup to the SonoreUPnP Bridge, which is GUI driven on the SonicOrbiterOS platform.


Just tried this, but it’s still no good, 48khz is the highest quality. Config XML resets back everytime

1 Like

Do you have to start the ifi bridge manually or can it auto start in Windows Startup

I have installed it , it sees my RPi Riopeee instance plus 4 others all with the same IP address, my Cambridge Audio CXN, so far i havent been able to play to it …

Ill try some more unless you have info it doesnt worl

1 Like

Hey Scott, I will send you a private message. :slight_smile: I think I may have a solution to your problem.

Hi i try to make it work but no sound i hear(
win10 roon software + iFi Bridge software i run UPnP … open squeezebox settings in roon and no sound who can help me to make it work with my x2 devialet phantom gold + dialog

1 Like

Hi @Jake_iFi

Am trying again !!

I see 4 versions all with the same IP address

I renamed one , what are the other 3 , any ideas

I reboot my core most days , can I simply put the bridge into my Win 10 Startup ?

1 Like

Hi Scott

With regard to the Phantoms, are you able to control the volume through Roon while using thr ifi bridge?

Or do you still need to use the remote or devealet app?

And did were you able to solve the issue with the max bitrate?


1 Like

T.b.h I’ve given up on it, my roon sub actually ends tomorrow. Due to the current Covid 19 saga I’m no longer working, so roon will have to go for the time being.

1 Like

Hi @Mike_O_Neill

I am unable to replicate this issue back at our end unfortunately.

Have you since managed to get it working? To hard restart to iFi Bridge go to:
Task manager > Services and close ‘Squeeze2upnp’. The bridge will pick up all upnp devices on your network which is why you may have so many.


Hi @Jake_iFi

I have rebooted PC, Restarted iFi Bridge

I now see

at the bottom , is the CXN , and is a MyGica Android box are both uPnP devices but not showing as SqueezeBox devices via the bridge .

I m not sure what is it comes up in the Router Network Map as HOMEGROUP

Any thoughts

Keep Well – Mike

Check your router to see what device it is. Any router should have the ability to see connected devices and their IP addresses. It’s.likely something you least expect with UPnP/DNLA support could be video and not audio to. As the plugin will find any UPnP compatible device on the Network.

It shows as Homegroup , which I believe is now defunct in Win 10 ,

So in your router that IP address shows as homegroup as the device? Is it not the pc the bridge is running on then?

No i can see the RPi, as riopeee xl but not the CXN, except as AirPlay

Very odd…

I have successfully installed the iFi Bridge and have been able to stream music from Roon server to my pro iDSD. Only issue is that hi-rez streams are being downsampled to 48kHz. I see this on the Roon signal path information as well as on the pro iDSD. I followed the instructions in the setup document. I have not changed any settings on the Squeezebox Device Setup settings within Roon other than MQA Capabilities.
I see that the “config.xml” generated by iFi Bridge after it scans devices contains “<sample_rate>48000</sample_rate>”. I have tried editing this manually to 192000 before i click “start bridge” but that has not helped.
Any ideas? Thanks.

Hey @mrr, could you send me a private message showing that the stream is down sampling? I have been testing this and I for some reason cannot replicate this issue!

We will be working on a solution to get 192kHz to work if we can, bare with me guys! I shall keep you all updated.