iFi iDSD Micro native DSD support in RoPieee

Hello, maybe someone can help me or give me a hint. I have installed the latest RoPieee on my Pi 3 and have hooked up my iFi iDSD Micro via USB. Everything works fine except the option of native DSD playback is not shown. How can I get it to work?
Thanks a lot for your help.

Hmmm… I would expect this to work. I do know there’s something with firmware for the iFi. @dabassgoesboomboom can you help out here?

Can you also send mee feedback (go to the ‘advanced’ tab) so I can have a look as well?


I don’t have the micro iDSD anyone to test unfortunately. I have the new Pro iDSD.

Hello Harry, what exact additional information can I provide to you? BTW: If I connect the iDSD Micro to a Windows machine the native DSD output is possible. So the firmware should be ok I think?

Kind regards

As I mentioned: send me feedback. Go to the advanced tab on the webpage and hit the ‘send feedback’ button.

Hi Harry,

sent you feedback with the following identifier


Hello Harry,

did you already find time to check that issue?

Kind regards

I can’t see. I remember there was something with having 2 choices of firmware: one with MQA support and one without. What are you using?

I have the latest one with MQA support.

Hi Harry, did you find out anything? Do I have to swith back to the firmware without MQA support?

You could try. I can’t see enough data from the feedback.

Is there a possibility that you can see more data? I would prefer to stay on the current firmware and would consider a downgrade only if you see no other chance to bring native dsd playback to work.

Have downgraded firmware but that didn’t help. Nevertheless native dsd support is not available. Any other idea?

You can try another feedback, but make sure you’re on the latest version AND you have the DAC powered on.

OK, have sent you feedback right now. Did you get it?
Identifier is 6599843d966dc452

Well, it seems the USB descriptor is not promoting the necessary stuff.
Only option left is switching firmware.

Hello Harry, I have tried several firmware versions but no one gave me the possibility to activate native dsd playback in RoPieee. Can you give me a hint, which firmware is supposed to be the correct one for native dsd playback with the iDSD Micro in RoPieee?
PS: Maybe you had conact with some RoPieee user out there who can confirm the correct firmware version and that native dsd playback works?

I’ve got a Nano iDSD black label with 5.30 on board.
That one works.

Have installed Firmware 5.30 on my iDSD Micro, but dsd native playback is still not possible. That‘s strange… Now I have no idea anymore and will give up. Obviously it is not possible to activate native dsd playback on iDSD Micro in RoPieee… Bummer.

Did you update to the latest version of RoPieee? 176 is released tonight.
After you updated can you send me feedback again?