Ifi idsd nano bl not recognised by ios remotes

Does anyone have a fix for this…Nano all of a sudden not being recognised by roon when hooked up to my iOS devices, (iPad and iPhone). It is still recognised as a zone on my Macbookpro when hard connected ,( and working normally),but not showing up in audio devices in settings now on the iOS devices when they are hard connected to it. The Nano was operating as a zone on all devices last time I used it a few days ago.For some reason it is no longer identified on iOS remotes??

Do you mean that the Apple device does not “see” (and then allow you to select) the Ifi Nano BL DAC even though the iPhone or iPad is working as a Roon endpoint?

I use an iPhone 5S with mine, and sometimes have to dis-connect and re-connect the lightning-to-USB cable with the Ifi powered ON in order to regain the external DAC option in the iOS speaker selection.

Thanks Brad,
My ipad and iphone 6s are still working as roon endpoints. What is not happening now is roon discovering the ifi nano when the nano is connected to them, even if I power the nano on/off, re connect it, connect it powered up ( as it is meant to be connected it ios devices) or anything else so far.
The screen shot below used to list the “ifi nano” as connected to this tablet. As can be seen, it is not listed even though it is connected to the ipad now (for some reason). So I can’t enable it and use the nano for a zone as I could a couple of days ago.

Ok…maybe I’m getting mixed up here. I now have the nano hooked up to my ipad and am playing an MQA album via roon. The screen indicated the zone as the ipad but the nano’s magenta mqa light is on, so I am listening to an decoded and rendered mqa file. That is ,roon has performed the first unfold and then passed the file onto the nano for rendering, even though the nano isn’t showing as being connected to my ipad in roons audio settings.
Maybe the macbookpro allows me to enable the nano and set it as a zone but ios devices don’t allow this.
So… when using the MBP connected to the nano, the nano can be selected as a zone. When using an ios device , the nano cannot be selected as a zone.
Is that correct?

We can’t detect individual USB devices on iOS–the output always follows whatever the iOS device is doing (speakers, headphones, bluetooth, airplay, usb). So there is only ever one device listed (unlike on Mac/PC/Linux).

That explains it . Thanks Brian. I was obviously getting confused. I was expecting what I saw on the MBP roon remote screen to be the same on IOS.