iFi iDSD Nano Black Label, Roon and MQA

I am considering purchasing one of these for headphone listening. Can I hook the nano up to an iPad or iPhone running roon remote ,( using the iOS device as an endpoint), and roon will allow me to use the nano volume control? The image below from the roon tested dacs page suggests no for volume control.I’m not sure what that means.

Can I also get full MQA unfolding with the above combination? ie, roon, via the iOS device will perform the first unfold and then the nano will perform the final unfold?

U can. You need to use the apple camera kit. Lightning to USB 3 Camera Adapter $39.

I have the micro blk version.

The camera kit separates the dac and volume control from the iphone/ipad so your nano use its vol ctrl and dac…pretty cool.
Aldo gets MQA with the new ifi firmware.

Thanks Larry,
Do you get the full mqa unfolding with the nano hooked up to the ios device as opposed to hooked up to the core device?

Is MQA available when streaming from an ios device?

If iOS can pass through 24/44.1/48k bit perfect without using volume control on iOS device itself, then it should able to pass the decoded information for the IFI to act as a ‘renderer’ to complete full MQA decoding.

Hello @James_O_Brien,

Yes, MQA Renderers like the iFi will complete the full MQA unfolding process when connected to an iOS device using Roon. The “first unfold” will happen on your Roon Core and then sent to your device.

The iFi iDSD Nano does not support USB HID Volume controls, so you will not be able to control it’s volume from within Roon or from the iOS device.


That’s fantastic news. The nano has a wonderful volume knob so I will be very happy to use that. A couple of questions;

1.What settings in roon regarding MQA should I choose for the nano?

  1. Also, when using this setup, will non MQA tracks such as flac 24/192, 24/96 , 16/44, mp3 etc play to full potential without further setting changes?

3.When hooking the iFi Nano up to my MBP ,I can enable the nano in roon audio settings and then use it as a zone on the MBP, ( remembering the roon core is on my nucleus). BUT when I hook the nano up to my iPad it does not show up in roon audio settings for me to enable it. Consequently the magenta MQA light on the nano isn’t lit when I play an MQA file over the iPad as it is lit magenta when I play via the MBP. What am I doing incorrectly?
4. what settings in roon audio settings re. MQA should I have the iPad set to when the Nano is involved? eg, no MQA support, decoder only etc. I assume I can get the magenta MQA light lit on the Nano with the correct settings on the iPad( or iPhone), as it is when connected to the MBP when playing a MQA file

As mentioned this will primarily be a headphone setup, either desktop connected to an ios device or Macbookpro, or rarely a mobile setup.


I have both the iDSD Micro and the iDAC2 Micro. The iDAC2 is by far, from my experience and iFi’s admission, the better DAC. Also, keeping the battery charged on the iDSD is a real PITA. The iDAC2 doesn’t have a battery. The iDSD can do DSD512. There is a firmware update for both that adds MQA.

For what it’s worth …

1 Like

Hello @James_O_Brien,

  1. Set the MQA Capabilities for the iDSD Nano to “Renderer only”.
  2. Yes.
  3. In the “Device Setup” screen for the iPad zone, set the MQA Capabilities to “Renderer only”. This will send the Core Decoded stream with rendering instructions to the iPad, which will then pass it along to the iDSD Nano for final rendering.
  4. See above.


1 Like

Thanks John, that magenta light is shining bright now. Fantastic.

1 Like

Does anyone have a fix for this…Nano all of a sudden not being recognised by roon on my iOS devices, (iPad and iPhone). It is still recognised as a zone on my Macbookpro ,( and working normally),but not showing up in audio devices in settings now on the iOS devices. The Nano was operating as a zone on all devices last time I used it a few days ago.For some reason it is no longer identified on iOS remotes??